source: build.properties @ 099cacd

Last change on this file since 099cacd was 099cacd, checked in by zzz <zzz@…>, 11 months ago

Installer: Fix -console install for izpack 5 (ticket #2492)
Switch to izpack 5 for non-windows release installer

  • Property mode set to 100644
File size: 7.3 KB
Line 
1# These properties can be set to alter the build process.
2#
3# This file contains default values that are used by official I2P installers.
4#
5# End-users *should not* edit this file. If you want to change the values, make a
6# copy, call it override.properties, and make the desired changes to that.
7
8################################################################################
9
10# Javadocs
11# Note: Include the trailing slash! Don't surround the URL in quotes!
12javasedocs.url=http://docs.oracle.com/javase/7/docs/api/
13javaeedocs.url=http://docs.oracle.com/javaee/7/api/
14# The following link is for 9.4.x
15#jettydocs.url=http://download.eclipse.org/jetty/stable-9/apidocs/
16jettydocs.url=http://download.eclipse.org/jetty/9.2.21.v20170120/apidocs/
17wrapperdocs.url=http://wrapper.tanukisoftware.com/jdoc/
18# these are only for unit test javadocs
19i2pdocs.url=http://docs.i2p-projekt.de/javadoc/
20junitdocs.url=http://junit.org/apidocs/
21# This will go in the jar manifests
22build.built-by=unknown
23
24# filename of the sloccount report
25sloccount.report.file=sloccount.sc
26
27# Uncomment the next line to prevent "ant debian" from automatically
28# updating the changelog
29#noAutoDebchange=true
30
31# Building EXEs in x64 Linux requires that 32bit libraries are installed. In Debian,
32# for example, installing the libc6-i386 package will satisfy this requirement.
33# Uncomment the next line to prevent building EXEs (changing it to false will have no impact)
34#noExe=true
35
36# IzPack 5.1.x install dir
37# Default is $HOME/IzPack
38#izpack5.home=/PATH/TO/IzPack
39# Default is 5.1.3
40#izpack5.version=5.1.3
41
42# Change this to false if you don't have gettext or you want to prevent it from running during the build
43require.gettext=true
44
45# Compile for this version of Java
46javac.version=1.7
47
48# Additional classpath if required
49#javac.classpath=/PATH/TO/pack200.jar
50
51# Optional compiler args
52# This one keeps gcj a lot quieter
53#javac.compilerargs=-warn:-unchecked,raw,unused,serial
54
55#
56# Note to packagers, embedders, distributors:
57#
58# Strictly speaking, you must either use the compiler for the minimum Java version you are
59# targeting (default 1.7, see above), or specify a bootclasspath, which means you need
60# the JRE for the target version installed as well.
61#
62# However, in practice, you can compile with 1.7 and target 1.6 without specifying a bootclasspath,
63# and it all works fine.
64#
65# But you cannot compile with 1.8 and target 1.6 or 1.7 without bootclasspath,
66# or your users will get runtime errors.
67# Below is an example of a bootclasspath that works on Ubuntu.
68#
69# For more info:
70#    http://zzz.i2p/topics/1668
71#    https://gist.github.com/AlainODea/1375759b8720a3f9f094
72#
73# You must set both.
74#
75# For embedded use only, and for a limited time,
76# the following subsystems ONLY may be built with Java 6 by setting javac.version=1.6 in override.properties,
77# and setting javac.compilerargs to use java 6 jars:
78# core, router, ministreaming, streaming, addressbook, i2ptunnel, BOB
79# Use the buildX ant targets to build these (see build.xml).
80# We may start using Java 7 features in these subsystems at any time and without notice.
81#javac.compilerargs=-bootclasspath /usr/lib/jvm/java-6-openjdk-amd64/jre/lib/rt.jar:/usr/lib/jvm/java-6-openjdk-amd64/jre/lib/jce.jar
82#
83# For standard builds, set both of the following in override.properties:
84#
85#javac.compilerargs=-bootclasspath /usr/lib/jvm/java-7-openjdk-amd64/jre/lib/rt.jar:/usr/lib/jvm/java-7-openjdk-amd64/jre/lib/jce.jar
86#javac.compilerargs7=-bootclasspath /usr/lib/jvm/java-7-openjdk-amd64/jre/lib/rt.jar:/usr/lib/jvm/java-7-openjdk-amd64/jre/lib/jce.jar
87
88
89### UnitTests ##
90# Uncomment the next line to enable integration tests.
91# These require a running router with I2CP available on 127.0.0.1:7654.
92#runIntegrationTests=true
93
94# Location of the libraries required for the ScalaTest tests.
95# Define this in override.properties or pass in on the command line.
96# The directory must contain the following library names:
97# scala-compiler.jar
98# scala-library.jar
99# scala-reflect.jar
100# scala-xml.jar
101# scalactic.jar
102# scalatest.jar
103# Tested using Scala 2.12.1, scala-xml 1.0.6, and ScalaTest 3.0.1
104#scalatest.libs=/PATH/TO/SCALATEST/lib
105
106# Location of the junit libraries
107# Defaults to the ant library path if not set.
108# If set, this must point to a directory that contains the file junit4.jar
109# Debian/Ubuntu: sudo apt-get install junit4
110#junit.home=/usr/share/java
111
112# Location of the hamcrest libraries
113# Defaults to the ant library path if not set
114# If set, this must point to a directory containing the files
115#       hamcrest-core.jar, hamcrest-library.jar, and hamcrest-integration.jar
116# Tested using Hamcrest 1.3
117# Debian/Ubuntu: sudo apt-get install libhamcrest-java
118#hamcrest.home=/usr/share/java
119
120# Location of the mockito libraries
121# Defaults to the ant library path if not set
122# If set, this must point to a directory containing the files
123#       mockito-core.jar, byte-buddy.jar, objenesis.jar
124# Tested using Mockito 2.5.0 which requires byte-buddy 1.5.12 and objenesis 2.4
125#mockito.home=
126
127# Optional properties used in tests to enable additional tools.
128#with.cobertura=/PATH/TO/cobertura.jar
129#with.clover=/PATH/TO/clover.jar
130
131
132### Benchmarks ##
133# Location of the JMH libraries
134# Defaults to the ant library path if not set
135# If set, this must point to a directory containing the files
136#       jmh-core.jar, jmh-generator-annprocess.jar, jopt-simple.jar, commons-math3.jar
137# Tested using JMH 1.19 which requires jopt-simple 4.6 and commons-math3 3.2
138#jmh.home=
139
140
141### Bundle router infos ###
142# Set to bundle router infos from your local I2P install in the package
143#bundle.routerInfos=true
144#bundle.routerInfos.count=200
145#bundle.routerInfos.i2pConfigDir=/PATH/TO/.i2p
146
147### Debian/Ubuntu packages ###
148# uncomment to try to make the build reproducible; work in progress
149#build.reproducible=true
150# Don't include geoip files, we will use geoip-database package
151#with-geoip-database=true
152# Don't include jetty files, we will use libjetty9-java package. Requires with-libtomcat8-java=true.
153#with-libjetty9-java=true
154# Don't include tomcat files, we will use libtomcat8-java package
155#with-libtomcat8-java=true
156# Don't include tomcat files, we will use libtomcat9-java package
157#with-libtomcat9-java=true
158# Don't include jstl.jar and standard.jar, we will use libtaglibs-standard-* packages
159#with-libtaglibs-standard=true
160# Don't include jstl.jar and standard.jar, we will use glassfish-javaee package
161#with-glassfish-javaee=true
162# Don't include standard.jar, we will use libjakarta-taglibs-standard-java package
163#with-libjakarta-taglibs-standard-java=true
164# Don't include jstl.jar, we will use libjstl1.1-java package
165#with-libjstl1.1-java=true
166# Don't compile GettextResource.java, we will use libintl.jar from the gettext-base package
167#with-gettext-base=true
168# Don't compile gnu.getopt classes, we will use libgetopt-java package
169#with-libgetopt-java=true
170# Don't bundle flags, we will use famfamfam-flag-png package
171#with-famfamfam-flag-png=true
172# Don't include json-simple library, we will use libjson-simple-java package
173#with-libjson-simple-java=true
174# Don't compile org.apache.http classes, we will use libhttpclient-java and libhttpcore-java packages
175# 2 MB of dependencies vs. 20 KB of copied source
176# Requires 4.4 or higher.
177# Debian: Not in wheezy/jessie
178# Ubuntu: Only in wily and later
179#with-libhttpclient-java=true
180
181### Redhat packages ###
182# uncomment to prevent classpaths in jar manifests
183# https://fedoraproject.org/wiki/Packaging:Java
184# without-manifest-classpath=true
Note: See TracBrowser for help on using the repository browser.