source: build.properties @ 11e8611

Last change on this file since 11e8611 was 11e8611, checked in by zzz <zzz@…>, 3 years ago

Build: Add support for using libtomcat8-java package, untested

  • Property mode set to 100644
File size: 6.2 KB
Line 
1# These properties can be set to alter the build process.
2#
3# This file contains default values that are used by official I2P installers.
4#
5# End-users *should not* edit this file. If you want to change the values, make a
6# copy, call it override.properties, and make the desired changes to that.
7
8################################################################################
9
10# Javadocs
11# Note: Include the trailing slash! Don't surround the URL in quotes!
12javasedocs.url=http://docs.oracle.com/javase/7/docs/api/
13javaeedocs.url=http://docs.oracle.com/javaee/7/api/
14# The following link is dead, perhaps temporarily,
15# perhaps not, as they move 7 and 8 to unsupported status.
16#jettydocs.url=http://download.eclipse.org/jetty/stable-8/apidocs/
17jettydocs.url=http://download.eclipse.org/jetty/8.1.17.v20150415/apidocs/
18jrobindocs.url=http://docs.i2p-projekt.de/jrobin/javadoc/
19wrapperdocs.url=http://wrapper.tanukisoftware.com/jdoc/
20# these are only for unit test javadocs
21i2pdocs.url=http://docs.i2p-projekt.de/javadoc/
22junitdocs.url=http://junit.org/apidocs/
23# This will go in the jar manifests
24build.built-by=unknown
25
26# filename of the sloccount report
27sloccount.report.file=sloccount.sc
28
29# Uncomment the next line to prevent "ant debian" from automatically
30# updating the changelog
31#noAutoDebchange=true
32
33# Building EXEs in x64 Linux requires that 32bit libraries are installed. In Debian,
34# for example, installing the libc6-i386 package will satisfy this requirement.
35
36# Uncomment the next line to prevent building EXEs (changing it to false will have no impact)
37#noExe=true
38
39# Change this to false if you don't have gettext or you want to prevent it from running during the build
40require.gettext=true
41
42# Compile for this version of Java
43javac.version=1.7
44
45# Additional classpath if required
46#javac.classpath=/PATH/TO/pack200.jar
47
48# Optional compiler args
49# This one keeps gcj a lot quieter
50#javac.compilerargs=-warn:-unchecked,raw,unused,serial
51
52#
53# Note to packagers, embedders, distributors:
54#
55# Strictly speaking, you must either use the compiler for the minimum Java version you are
56# targeting (default 1.7, see above), or specify a bootclasspath, which means you need
57# the JRE for the target version installed as well.
58#
59# However, in practice, you can compile with 1.7 and target 1.6 without specifying a bootclasspath,
60# and it all works fine.
61#
62# But you cannot compile with 1.8 and target 1.6 or 1.7 without bootclasspath,
63# or your users will get runtime errors.
64# Below is an example of a bootclasspath that works on Ubuntu.
65#
66# For more info:
67#    http://zzz.i2p/topics/1668
68#    https://gist.github.com/AlainODea/1375759b8720a3f9f094
69#
70# You must set both.
71#
72# For embedded use only, and for a limited time,
73# the following subsystems ONLY may be built with Java 6 by setting javac.version=1.6 in override.properties,
74# and setting javac.compilerargs to use java 6 jars:
75# core, router, ministreaming, streaming, addressbook, i2ptunnel, BOB
76# Use the buildX ant targets to build these (see build.xml).
77# We may start using Java 7 features in these subsystems at any time and without notice.
78#javac.compilerargs=-bootclasspath /usr/lib/jvm/java-6-openjdk-amd64/jre/lib/rt.jar:/usr/lib/jvm/java-6-openjdk-amd64/jre/lib/jce.jar
79#
80# For standard builds, set both of the following in override.properties:
81#
82#javac.compilerargs=-bootclasspath /usr/lib/jvm/java-7-openjdk-amd64/jre/lib/rt.jar:/usr/lib/jvm/java-7-openjdk-amd64/jre/lib/jce.jar
83#javac.compilerargs7=-bootclasspath /usr/lib/jvm/java-7-openjdk-amd64/jre/lib/rt.jar:/usr/lib/jvm/java-7-openjdk-amd64/jre/lib/jce.jar
84
85
86### UnitTests ##
87# Uncomment the next line to enable integration tests.
88# These require a running router with I2CP available on 127.0.0.1:7654.
89#runIntegrationTests=true
90
91# Location of the libraries required for the ScalaTest tests.
92# Define this in override.properties or pass in on the command line.
93# The directory must contain the following library names:
94# mockito-all.jar
95# scala-compiler.jar
96# scala-library.jar
97# scalatest.jar
98#scalatest.libs=/PATH/TO/SCALATEST/lib
99
100# Location of the junit libraries
101# Defaults to the ant library path if not set.
102# If set, this must point to a directory that contains the file junit4.jar
103#junit.home=
104
105# Location of the hamcrest libraries
106# Defaults to the ant library path if not set
107# If set, this must point to a directory containing the files
108#       hamcrest-core.jar, hamcrest-library.jar, and hamcrest-integration.jar
109#hamcrest.home=
110
111# Location of the mockito libraries
112# Defaults to the ant library path if not set
113# If set, this must point to a directory containing the files
114#       mockito-core.jar, byte-buddy.jar, objenesis.jar
115#mockito.home=
116
117# Optional properties used in tests to enable additional tools.
118#with.cobertura=/PATH/TO/cobertura.jar
119#with.clover=/PATH/TO/clover.jar
120
121### Bundle router infos ###
122# Set to bundle router infos from your local I2P install in the package
123#bundle.routerInfos=true
124#bundle.routerInfos.count=200
125#bundle.routerInfos.i2pConfigDir=/PATH/TO/.i2p
126
127### Debian/Ubuntu packages ###
128# Don't include geoip files, we will use geoip-database package
129#with-geoip-database=true
130# Don't include jetty files, we will use libjetty8-java package
131#with-libjetty8-java=true
132# Don't include tomcat files, we will use libtomcat6-java package
133#with-libtomcat6-java=true
134# Don't include tomcat files, we will use libtomcat7-java package
135#with-libtomcat7-java=true
136# Don't include tomcat files, we will use libtomcat8-java package
137#with-libtomcat8-java=true
138# Don't include jstl.jar and standard.jar, we will use glassfish-javaee package
139#with-glassfish-javaee=true
140# Don't include standard.jar, we will use libjakarta-taglibs-standard-java package
141#with-libjakarta-taglibs-standard-java=true
142# Don't include jstl.jar, we will use libjstl1.1-java package
143#with-libjstl1.1-java=true
144# Don't compile GettextResource.java, we will use libintl.jar from the gettext-base package
145#with-gettext-base=true
146# Don't compile gnu.getopt classes, we will use libgetopt-java package
147#with-libgetopt-java=true
148# Don't compile org.apache.http classes, we will use libhttpclient-java and libhttpcore-java packages
149# 2 MB of dependencies vs. 20 KB of copied source
150# Requires 4.4 or higher.
151# Debian: Not in wheezy/jessie
152# Ubuntu: Only in wily and later
153#with-libhttpclient-java=true
Note: See TracBrowser for help on using the repository browser.