Ignore:
Timestamp:
Feb 3, 2014 11:24:45 PM (7 years ago)
Author:
zzz <zzz@…>
Branches:
master
Children:
fe391ff2
Parents:
c59603d
Message:
  • Jetty:
    • Update to Jetty 8.x, Servlet 3.0, JSP 2.2
    • Require Java 6
    • Use Servlet and JSP jars from Jetty instead of Tomcat
    • Tomcat remains at 6.0.37 supporting Servlet 2.5 / JSP 2.1
    • Remove Jetty dependency in console error pages
    • Build files for Jetty 8.1.14
    • Doc updates
    • Delete Jetty 7.6.14
    • Jetty 8.1.14 not yet checked in, waiting to see if a new version is released soon, but build will download it for testing
File:
1 edited

Legend:

Unmodified
Added
Removed
  • apps/jetty/apache-tomcat-deployer/README-i2p.txt

    rc59603d r001b127  
    77minus the following files and directores:
    88
    9 build.xml
    10 deployer-howto.html
    11 images/*
    12 lib/catalina*
    13 LICENSE (see ../../../licenses/LICENSE-Apache2.0.txt, it's also inside every jar)
    14 RELEASE-NOTES
     9        build.xml
     10        deployer-howto.html
     11        images/*
     12        lib/catalina*
     13        lib/jsp-api.jar (see below)
     14        lib/servlet-api.jar (see below)
     15        LICENSE (see ../../../licenses/LICENSE-Apache2.0.txt, it's also inside every jar)
     16        RELEASE-NOTES
     17
     18
     19We could use the following API jars from Apache Tomcat 7.x, supporting Servlet 3.0 and JSP 2.2,
     20that are required for Jetty 8, but we just bundle the ones from Jetty 8 instead:
     21
     22        lib/jsp-api.jar
     23        lib/servlet-api.jar
     24
     25For more info:
     26http://tomcat.apache.org/whichversion.html
Note: See TracChangeset for help on using the changeset viewer.