Changeset 094cf14 for history.txt


Ignore:
Timestamp:
Apr 7, 2016 2:38:30 PM (4 years ago)
Author:
zzz <zzz@…>
Branches:
master
Children:
5a2975b
Parents:
5c8eab9
Message:

Debian:
Prep for dependency on libtomcat7
Doesn't work yet, breaks susidns.
glassfish-javaee for jstl.jar and standard.jar version 1.2 won't work with tomcat7,
it's ancient and not compatible with recent el libs.
Add back option to depend on libjakarta-taglibs-standard and libjstl1.1-java which are version 1.1.2,
but not clear if they will work with tomcat7 either, even though they are
dependencies of libjetty8-extra-java.
We switched from JSTL 1.1.2 to JSTL 1.2 when we went from Jetty 5 to Jetty 6 in 2012.
1.2 libs are not available anywhere except for Glassfish, and
Debian only has the ancient Java EE 5 Glassfish 2.1.
Not clear there's any way to get susidns (and bote) to work with both Tomcat 6 and 7.

  • Fix wrong jsp-api version
  • Fix other minor errors in install and links files.
  • Log stack trace for Jetty warnings if log level is WARN
  • SusiDNS: Move standard.jar and jstl.jar out of WEB-INF/lib, where Tomcat 7 build refuses to find them
File:
1 edited

Legend:

Unmodified
Added
Removed
  • history.txt

    r5c8eab9 r094cf14  
     12016-04-07 zzz
     2 * Debian builds:
     3   - Prep for depending on tomcat packages
     4   - Minor fixes
     5
     62016-04-04 zzz
     7 * Debian builds:
     8   - Depend on glassfish-javaee for JSTL 1.2 by default
     9
    1102016-04-03 zzz
    211 * Debian builds:
Note: See TracChangeset for help on using the changeset viewer.