Changeset 16ff3e3 for debian


Ignore:
Timestamp:
May 5, 2016 11:41:05 AM (4 years ago)
Author:
zzz <zzz@…>
Branches:
master
Children:
75d6df77
Parents:
0839b46
Message:

Debian: Refresh patch after i2prouter change

File:
1 edited

Legend:

Unmodified
Added
Removed
  • debian/patches/0001-path-substitution.patch

    r0839b46 r16ff3e3  
    7272 # Priority at which to run the wrapper.  See "man nice" for valid priorities.
    7373 #  nice is only used if a priority is specified.
    74 @@ -177,75 +168,8 @@
     74@@ -177,77 +168,8 @@
    7575        exit 1
    7676 fi
     
    105105-freebsd10() {
    106106-    echo
    107 -    echo "The current version of the Tanuki wrapper does not"
    108 -    echo "support FreeBSD 10."
     107-    echo "The current version of the Tanuki wrapper that is bundled"
     108-    echo "with I2P does not support FreeBSD 10."
    109109-    echo
    110 -    echo "See https://trac.i2p2.de/ticket/1118 for more information"
    111 -    echo "and a workaround for this issue."
     110-    echo "See http://trac.i2p2.de/ticket/1118#comment:13 for a work-around."
     111-    echo "After applying the work-around, as a normal user or a dedicated"
     112-    echo "i2p user, you can then run:"
     113-    echo "$ ./i2prouter start"
    112114-    echo
    113 -    echo "In the meantime, you may start I2P by running the script"
     115-    echo "Or, you may also start I2P by running the script:"
    114116-    echo "${I2P}/runplain.sh"
    115117-    echo
     
    126128-                *)
    127129-                    # We should never get here on recent versions of FreeBSD
    128 -                    if ! $(pkg_info -E 'libiconv*' > /dev/null 2>&1); then
     130-                    if ! $(pkg info -E 'libiconv*' > /dev/null 2>&1); then
    129131-                        echo
    130132-                        echo "The wrapper requires libiconv."
    131133-                        echo
    132 -                        echo "It can be installed with pkg_add -r libiconv"
     134-                        echo "It can be installed with pkg install libiconv"
    133135-                        echo
    134136-                    fi
     
    148150 then
    149151     COMMAND="$FIXED_COMMAND"
    150 @@ -1058,7 +982,6 @@
     152@@ -1068,7 +982,6 @@
    151153         if [ "X$pid" = "X" ]
    152154         then
     
    156158             eval echo ' running: PID:$pid'
    157159         fi
    158 @@ -1861,7 +1784,7 @@
     160@@ -1871,7 +1784,7 @@
    159161 }
    160162 
     
    165167 
    166168 checkifstartingasroot() {
    167 @@ -1869,7 +1792,7 @@
     169@@ -1879,7 +1792,7 @@
    168170         echo "`gettext 'Running I2P as the root user is *not* recommended.'`"
    169171         showsetusermesg
     
    174176     fi
    175177 }
    176 @@ -1934,24 +1857,10 @@
     178@@ -1944,24 +1857,10 @@
    177179             status
    178180             ;;
Note: See TracChangeset for help on using the changeset viewer.