Ignore:
Timestamp:
Sep 23, 2018 3:33:29 AM (2 years ago)
Author:
meeh <meeh@…>
Branches:
master
Children:
e59d7a82
Parents:
3b38f5a
Message:

Mac OS X Launcher:

  • Bugfixes as always
  • Added Sparkle (native updater, https://sparkle-project.org/ )
  • The launcher will now extract and overwrite older versions if found
  • Rewrite of the java extraction part (to enable overwrite)
  • Move more functionality to use EventManager? as it works quite well
  • Added check for updates menu item
File:
1 edited

Legend:

Unmodified
Added
Removed
  • launchers/macosx/I2PLauncher/routermgmt/RouterManager.swift

    r3b38f5a r7a72049  
    3939    if (packedVersion.compare(currentVersion, options: .numeric) == .orderedDescending) {
    4040      Swift.print("event! - router version: Packed version is newer, gonna re-deploy")
     41      RouterManager.shared().eventManager.trigger(eventName: "router_must_upgrade", information: "got new version")
    4142    } else {
    4243      Swift.print("event! - router version: No update needed")
Note: See TracChangeset for help on using the changeset viewer.