Changeset 7e80379 for Slackware


Ignore:
Timestamp:
Sep 21, 2009 8:54:41 AM (11 years ago)
Author:
sponge <sponge@…>
Branches:
master
Children:
2dd650d
Parents:
5eccc01
Message:
  • fixups to SlackBuilds?. requiredbuilder does the wrong thing, and thinks that java is perl! This isn't really a big deal, the file format is simple enough and the requirements are known.
Location:
Slackware
Files:
3 edited

Legend:

Unmodified
Added
Removed
  • Slackware/i2p-base/i2p-base.SlackBuild

    r5eccc01 r7e80379  
    2525NAME=i2p-base
    2626VERSION=0.0.1
    27 BUILD=1sim
     27BUILD=1sponge
    2828ARCH=noarch
    2929INSTALL_DIR=opt
     
    3939
    4040cd $PKG
    41 requiredbuilder -v -y -s $CWD $PKG
     41#
     42# Not really that important to exec this.
     43#requiredbuilder -v -y -s $CWD $PKG
     44#
     45cat $CWD/slack-required > $PKG/install/slack-required
    4246makepkg -l y -c n $CWD/${NAME}-$VERSION-$ARCH-$BUILD.tgz
  • Slackware/i2p/i2p.SlackBuild

    r5eccc01 r7e80379  
    1616# For any additional information, visit i2host.i2p and forum.i2p
    1717
    18 BUILD=1sim
     18BUILD=1sponge
    1919
    2020# put here installation dir, without first and last /
     
    114114
    115115cd $PKG
    116 requiredbuilder -v -y -s $CWD $PKG
     116#
     117# requiredbuilder fucks up REALLY bad, and thinks java is perl?!
     118# It also did not catch the shell requirements! BOOOOOOOOOOO! HISSSSSSSS!
     119#
     120#requiredbuilder -v -y -s $CWD $PKG
     121#
     122cat $CWD/slack-required > $PKG/install/slack-required
    117123makepkg -l y -c n $CWD/${NAME}-$VERSION-$ARCH-$BUILD.tgz
  • Slackware/i2p/slack-required

    r5eccc01 r7e80379  
    1 glibc >= 2.7-i486-17 | glibc-solibs >= 2.7-i486-17
    2 perl >= 5.10.0-i486-1
     1jre >= 5
     2i2p-base >= 0.0.1
     3bash >= 3.1.017
     4
Note: See TracChangeset for help on using the changeset viewer.