Changeset 80973ca for apps


Ignore:
Timestamp:
Jul 18, 2018 1:15:36 PM (2 years ago)
Author:
zzz <zzz@…>
Branches:
master
Children:
412fcfb
Parents:
1b0102b
Message:

Build: Add check for libtaglibs package in debian builds

File:
1 edited

Legend:

Unmodified
Added
Removed
  • apps/susidns/src/build.xml

    r1b0102b r80973ca  
    5353        </target>
    5454
    55     <target name="precompilejsp" unless="precompilejsp.uptodate">
     55    <target name="verifylibtaglibs" if="${with-libtaglibs-standard}" >
     56        <!-- lib/jstlel.jar should be a symlink to the package jar.
     57           - If the package jar is not there, we will still compile fine but it won't run,
     58           - so catch it here.
     59          -->
     60        <fail message="libtaglibs-standard-jstlel-java package must be installed for debian builds">
     61            <condition>
     62                <not><available file="lib/jstlel.jar" type="file"/></not>
     63            </condition>
     64        </fail>
     65    </target>
     66
     67    <target name="precompilejsp" depends="verifylibtaglibs" unless="precompilejsp.uptodate">
    5668        <delete file="WEB-INF/web-fragment.xml" />
    5769        <delete file="WEB-INF/web-out.xml" />
Note: See TracChangeset for help on using the changeset viewer.