Opened 6 years ago

Closed 6 years ago

#1011 closed defect (not a bug)

Fehler 500: /netdb Server Error

Reported by: DISABLED Owned by:
Priority: minor Milestone: 0.9.8
Component: other Version: 0.9.7.1
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

Fehler 500: /netdb Server Error

java.lang.OutOfMemoryError?: Java heap space

at java.util.Arrays.copyOf(Arrays.java:2367)
at java.lang.AbstractStringBuilder?.expandCapacity(AbstractStringBuilder?.java:130)
at java.lang.AbstractStringBuilder?.ensureCapacityInternal(AbstractStringBuilder?.java:114)
at java.lang.AbstractStringBuilder?.append(AbstractStringBuilder?.java:587)
at java.lang.StringBuilder?.append(StringBuilder?.java:214)
at net.i2p.data.Base64.encode3to4(Base64.java:410)
at net.i2p.data.Base64.encodeBytes(Base64.java:535)
at net.i2p.data.Base64.safeEncode(Base64.java:451)
at net.i2p.data.Base64.encode(Base64.java:78)
at net.i2p.data.Base64.encode(Base64.java:62)
at net.i2p.data.Base64.encode(Base64.java:55)
at net.i2p.data.SimpleDataStructure?.toBase64(SimpleDataStructure?.java:98)
at net.i2p.data.Hash.toBase64(Hash.java:95)
at net.i2p.router.web.NetDbRenderer?$RouterInfoComparator?.compare(NetDbRenderer?.java:72)
at net.i2p.router.web.NetDbRenderer?$RouterInfoComparator?.compare(NetDbRenderer?.java:70)
at java.util.TreeMap?.put(TreeMap?.java:545)
at java.util.TreeSet?.add(TreeSet?.java:255)
at java.util.AbstractCollection?.addAll(AbstractCollection?.java:334)
at java.util.TreeSet?.addAll(TreeSet?.java:312)
at net.i2p.router.web.NetDbRenderer?.renderStatusHTML(NetDbRenderer?.java:264)
at net.i2p.router.web.NetDbHelper?.getNetDbSummary(NetDbHelper?.java:72)
at net.i2p.router.web.jsp.netdb_jsp._jspService(netdb_jsp.java:333)
at org.apache.jasper.runtime.HttpJspBase?.service(HttpJspBase?.java:70)
at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:723)
at org.eclipse.jetty.servlet.ServletHolder?.handle(ServletHolder?.java:652)
at org.eclipse.jetty.servlet.ServletHandler?.doHandle(ServletHandler?.java:445)
at org.eclipse.jetty.server.handler.ScopedHandler?.handle(ScopedHandler?.java:137)
at org.eclipse.jetty.security.SecurityHandler?.handle(SecurityHandler?.java:521)
at org.eclipse.jetty.server.session.SessionHandler?.doHandle(SessionHandler?.java:227)
at org.eclipse.jetty.server.handler.ContextHandler?.doHandle(ContextHandler?.java:1044)
at org.eclipse.jetty.servlet.ServletHandler?.doScope(ServletHandler?.java:372)
at org.eclipse.jetty.server.session.SessionHandler?.doScope(SessionHandler?.java:189)


I2P-Version & Laufzeitumgebung

I2P version: 0.9.7.1-0-deb1p1
Java version: Oracle Corporation 1.7.0_25 (OpenJDK Runtime Environment 1.7.0_25-b30)
Wrapper version: 3.5.19
Server version: 7.6.11.v20130520
Servlet version: Jasper JSP 2.1 Engine
Platform: Linux i386 2.6.32-042stab079.6
Processor: Phenom II X4/X6 (Zosma/Thuban? AM3, 45 nm) (athlon64)
Jbigi: Locally optimized native BigInteger? library loaded from file
Encoding: ANSI_X3.4-1968
Charset: US-ASCII

Beachten Sie, dass Systeminformationen, Zeitstempel der Berichte sowie die Fehlerberichte selbst Hinweise auf Ihren Standort enthalten können. Bitte überprüfen Sie Fehlerberichte, die Sie einreichen wollen, diesbezüglich!

Subtickets

Change History (2)

comment:1 Changed 6 years ago by DISABLED

ubuntu 12.04 lts min
vps

comment:2 Changed 6 years ago by zzz

Component: unspecifiedother
Resolution: not a bug
Status: newclosed

You just ran out of heap. You may wish to lower the maxMemory setting in wrapper.config, and/or lower your bandwidth or the services you are running. All of that will help the router use less memory. Cheap VPS services are problematic because they often don't provide enough memory.

Note: See TracTickets for help on using tickets.