Opened 6 years ago

Closed 6 years ago

#1015 closed defect (not a bug)

OutOfMemoryError: Java heap space

Reported by: DISABLED Owned by:
Priority: minor Milestone: 0.9.8
Component: unspecified Version: 0.9.7.1
Keywords: Cc: zab@…
Parent Tickets: Sensitive: no

Description

OutOfMemoryError?: Java heap space
This happens every few days.
I2P version: 0.9.7.1-0
Java version: Oracle Corporation 1.7.0_25 (Java™ SE Runtime Environment 1.7.0_25-b17)
Wrapper version: none
Server version: 7.6.11.v20130520
Servlet version: Jasper JSP 2.1 Engine
Platform: Windows 7 amd64 6.1
Processor: uninitialized (unrecognized)
Jbigi: Locally optimized native BigInteger? library loaded from file
Encoding: %encoding%
Charset: %charset%

Java 7 Update 25 (64-bit)
wrapper.java.maxmemory=512
router.maxParticipatingTunnels=5000 but ~2000 actually

Subtickets

Attachments (1)

log.txt (18.9 KB) - added by DISABLED 6 years ago.
log

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by DISABLED

Attachment: log.txt added

log

comment:1 Changed 6 years ago by Zlatin Balevsky

Cc: zab@… added

from the log:
mem: 109838336
I think you're not passing properly the max memory parameter

comment:2 in reply to:  1 Changed 6 years ago by DISABLED

Replying to zab:

from the log:
mem: 109838336
I think you're not passing properly the max memory parameter

line from wrapper.config
wrapper.java.maxmemory=512

What am I doing wrong?

comment:3 Changed 6 years ago by zzz

Resolution: not a bug
Status: newclosed

wrapper.java.maxmemory=512

That looks correct. So you either edited the wrong file, or didn't completely stop and then restart the wrapper after changing it, or there's an OS or VM restriction on available memory. I suspect that Windows is limiting it? If you can't increase it then you should reduce your max participating tunnels, and/or bandwidth, and/or max peers, and/or number of torrents in i2psnark.

FYI the max memory is shown on the memory graph on the graphs page in the console.

Good luck.

Note: See TracTickets for help on using tickets.