Opened 6 years ago

Closed 6 years ago

#1018 closed defect (not a bug)

Watchdog starts barking

Reported by: DISABLED Owned by:
Priority: minor Milestone:
Component: unspecified Version: 0.9.7.1
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

I2P version: 0.9.7.1-0
Java version: Oracle Corporation 1.7.0_25 (OpenJDK Runtime Environment 1.7.0_25-b30)
Wrapper version: 3.5.19
Server version: 7.6.11.v20130520
Servlet version: Jasper JSP 2.1 Engine
Platform: Linux amd64 3.2.0-53-generic
Processor: uninitialized (unrecognized)
Jbigi: Native BigInteger library jbigi not loaded - using pure Java - poor performance may result - see http://www.i2p2.i2p/jbigi for help
Encoding: UTF-8
Charset: UTF-8

The (large) thread dump can be found here:
http://pastethis.i2p/show/brVBbYqGXcj3s2sUc9ru/

Relevant router logs:

9/11/13 8:35:24 AM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: Memory: 71.40M/113.81M
9/11/13 8:35:24 AM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: Outbound send rate: 117844.90775461227 Bps
9/11/13 8:35:24 AM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: 1minute send processing time: 602.830891819939
9/11/13 8:35:24 AM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: Participating tunnel count: 1995
9/11/13 8:35:24 AM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: Job lag: 0
9/11/13 8:35:24 AM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: Ready and waiting jobs: 0
9/11/13 8:35:24 AM ERROR [uterWatchdog] client.ClientManagerFacadeImpl: Client D8zV8~ has a leaseSet that expired 10m

It seems like watchdog barking is something I should report when it goes on. The machine in use is high spec.

Subtickets

Change History (3)

comment:1 Changed 6 years ago by DISABLED

Another machine is barking..

I2P version: 0.9.7.1-0
Java version: Oracle Corporation 1.7.0_25 (OpenJDK Runtime Environment 1.7.0_25-mockbuild_2013_07_01_09_04-b00)
Wrapper version: 3.5.15
Server version: 7.6.11.v20130520
Servlet version: Jasper JSP 2.1 Engine
Platform: Linux i386 2.6.32-358.14.1.el6.i686
Processor: uninitialized (athlon)
Jbigi: Locally optimized native BigInteger library loaded from file
Encoding: UTF-8
Charset: UTF-8

Relevant router logs:

11/09/13 01:44:35 CRIT [uterWatchdog] et.i2p.router.tasks.ThreadDump: Threads dumped to wrapper log
11/09/13 01:44:35 CRIT [uterWatchdog] 2p.router.tasks.RouterWatchdog: Router appears hung, or there is severe network congestion. Watchdog starts barking!
11/09/13 01:44:35 ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: Memory: 150.90M/328.69M
11/09/13 01:44:35 ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: Outbound send rate: 267014.90895637305 Bps
11/09/13 01:44:35 ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: 1minute send processing time: 362.85447488575335
11/09/13 01:44:35 ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: Participating tunnel count: 1604
11/09/13 01:44:35 ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: Job lag: 0
11/09/13 01:44:35 ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: Ready and waiting jobs: 0
11/09/13 01:44:35 ERROR [uterWatchdog] client.ClientManagerFacadeImpl: Client xxxxx has a leaseSet that expired 10m

Thread dump: http://pastethis.i2p/show/0X4BXCSi9Mzs3DFaxyQK/

comment:2 Changed 6 years ago by Eche|on

Component: unspecifiedapi/crypto
Type: defectenhancement

<eche|on> ok, Processor: uninitialized (unrecognized) is the general problem
<eche|on> so I2P did not choose a asm-libjbigi and from time to time, the process of routing tunnel message takes too long time
<eche|on> and watchdog think, router hung

comment:3 Changed 6 years ago by zzz

Component: api/cryptounspecified
Milestone: 0.9.8
Resolution: not a bug
Status: newclosed
Type: enhancementdefect

No, don't worry about unrecognized processor.

Thread dump looks fine.

Just couldn't build the tunnels for your destination for 10 minutes. Maybe network congestion, or temporary internet connection problem, or a very busy CPU.

Hopefully just a transient problem. If it continues to occur, look for any reasons why it's having trouble building tunnels.

Note: See TracTickets for help on using tickets.