Opened 5 years ago

Closed 5 years ago

#1023 closed defect (worksforme)

Tracker error locks up snark

Reported by: guest Owned by: zzz
Priority: major Milestone: 0.9.9
Component: apps/i2psnark Version: 0.9.7.1
Keywords: snark tracker error stop peers Cc:
Parent Tickets:

Description

When you add several trackers, as reccomend in this thread http://forum.i2p/viewtopic.php?p=51718 it it likely that one or more will be unreachable or down when you attempt to contact all of them. But in i2psnark if just one of the trackers has an error then no more are contacted, resulting in a single tracker error making a torrent have 0 peers, and thus no download or upload. It seems that the DHT is also not queried in this situation.

Subtickets

Change History (8)

comment:1 Changed 5 years ago by zzz

  • Milestone set to 0.9.9

Shouldn't be like that (obviously). It all looks ok from a glance at the code. Perhaps the TrackerClient? loop is hanging?

Logging org.klomp.snark.TrackerClient?=DEBUG will give clues.

Will try to reproduce.

comment:2 Changed 5 years ago by zzz

I have tried and failed to reproduce this.

When it gets stuck, please take a thread dump and look for something stuck in TrackerClient? code.

comment:3 Changed 5 years ago by guest

I recall Oskar of Nightweb mentioning that snark dosen't actively look for peers once a torrent is completed. Could it be a combination of this on seeding torrents, genuinely no peers on downloading torrents, and an unrelated tracker error causing a correlation/causation mistake? Perhaps the logo of a torrent chnanging to an error in the case of a single tracker error dosen't help the situation.

comment:4 Changed 5 years ago by guest

  • Resolution set to worksforme
  • Status changed from new to closed

comment:5 Changed 5 years ago by str4d

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:6 Changed 5 years ago by guest

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:7 Changed 5 years ago by str4d

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:8 Changed 5 years ago by zzz

  • Resolution set to worksforme
  • Status changed from reopened to closed

Unable to reproduce here.

Note: See TracTickets for help on using tickets.