Opened 6 years ago

Closed 6 years ago

#1024 closed enhancement (fixed)

Specify required Java version in news file

Reported by: zzz Owned by: zzz
Priority: minor Milestone: 0.9.9
Component: router/update Version: 0.9.7.1
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

Eventually we will require Java 6 or even 7. To prevent a router from updating to something it can't run, specify the minimum Java version in the news.xml file. (e.g. minJavaVersion="6")

Router will check the value and throw up a message if Java is too old.

This may require enhancements to the update system - available-but-can't-update versions?

Subtickets

Change History (6)

comment:1 Changed 6 years ago by zzz

Owner: set to zzz
Status: newaccepted

Implmented in i2p.i2p.zzz.test2 branch 2a068082087d329d6ca7aada25ae044e4a626934 to be propped for 0.9.9

comment:2 Changed 6 years ago by DISABLED

Resolution: worksforme
Status: acceptedclosed

comment:3 Changed 6 years ago by str4d

Resolution: worksforme
Status: closedreopened

comment:4 Changed 6 years ago by DISABLED

Resolution: worksforme
Status: reopenedclosed

comment:5 Changed 6 years ago by str4d

Resolution: worksforme
Status: closedreopened

comment:6 Changed 6 years ago by zzz

Resolution: fixed
Status: reopenedclosed

Propped as 0.9.8.1-2

Note: See TracTickets for help on using tickets.