Opened 5 years ago

Closed 5 years ago

#1044 closed defect (not a bug)

klomp.snark.ConnectionAcceptor: Error while accepting

Reported by: guest Owned by:
Priority: minor Milestone: 0.9.8
Component: streaming Version: 0.9.7.1
Keywords: Cc:
Parent Tickets:

Description

I2P version: 0.9.7.1-0
Java version: Oracle Corporation 1.7.0_25 (OpenJDK Runtime Environment 1.7.0_25-b30)
Wrapper version: 3.5.19
Server version: 7.6.11.v20130520
Servlet version: Jasper JSP 2.1 Engine
Platform: Linux amd64 3.8.0-29-generic
Processor: Core 2 (Conroe) (core2)
Jbigi: Locally optimized native BigInteger? library loaded from file
Encoding: UTF-8
Charset: UTF-8

23/09/13 19:47:45 ERROR [ark acceptor] klomp.snark.ConnectionAcceptor?: Error while accepting

net.i2p.I2PException: destroyed
at net.i2p.client.streaming.I2PSocketManagerFull.verifySession(I2PSocketManagerFull.java:207)
at net.i2p.client.streaming.I2PSocketManagerFull.receiveSocket(I2PSocketManagerFull.java:127)
at net.i2p.client.streaming.I2PServerSocketFull.accept(I2PServerSocketFull.java:26)
at org.klomp.snark.ConnectionAcceptor?.run(ConnectionAcceptor?.java:152)
at java.lang.Thread.run(Thread.java:724)
at net.i2p.util.I2PThread.run(I2PThread.java:85)

Subtickets

Change History (2)

comment:1 Changed 5 years ago by guest

Possibly related: I stopped all torrents, waited for start button to appear again and started some torrents. This error came from ROUGHLY the same time but it may not be related.

comment:2 Changed 5 years ago by zzz

  • Component changed from unspecified to streaming
  • Resolution set to not a bug
  • Status changed from new to closed

This is indeed caused by stopping snark.

You probably hadn't seen this message before, as the exception is new in 0.9.7. It was a part of ongoing work to clean up locking with starting and stopping I2CP sessions. The message could probably be friendlier than just "destroyed".

Note: See TracTickets for help on using tickets.