Opened 6 years ago

Closed 6 years ago

#1057 closed defect (duplicate)

After upgrading to 9.8, router does not start

Reported by: DISABLED Owned by:
Priority: blocker Milestone: 0.9.9
Component: router/general Version: 0.9.8
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

I2P version: 0.9.8-0

Java version: Oracle Corporation 1.7.0_40 (Java™ SE Runtime Environment 1.7.0_40-b43)
Wrapper version: 3.5.19
Server version: 7.6.12.v20130726
Servlet version: Jasper JSP 2.1 Engine
Platform: Windows Server 2012 x86 6.2
Processor: uninitialized (unrecognized)
Jbigi: Locally optimized native BigInteger? library loaded from file
Encoding: Cp1252
Charset: windows-1252

Note that system information, log timestamps, and log messages may provide clues to your location; please review everything you include in a bug report.
Critical Logs

10/1/13 12:42:43 AM CRIT 1/1? net.i2p.router.JobQueueRunner? : Error processing job [Load Router Info] on thread 0: null

java.lang.IllegalStateException?
at net.i2p.data.RouterInfo?.setAddresses(RouterInfo?.java:185)
at net.i2p.router.startup.RebuildRouterInfoJob?.rebuildRouterInfo(RebuildRouterInfoJob?.java:122)
at net.i2p.router.startup.LoadRouterInfoJob?.runJob(LoadRouterInfoJob?.java:48)
at net.i2p.router.JobQueueRunner?.runCurrentJob(JobQueueRunner?.java:134)
at net.i2p.router.JobQueueRunner?.run(JobQueueRunner?.java:75)
at java.lang.Thread.run(Unknown Source)
at net.i2p.util.I2PThread.run(I2PThread.java:85)

Router Logs (configure)

File location: C:\ProgramData?\Application Data\i2p\logs\log-router-0.txt

10/1/13 12:44:43 AM ERROR [rtup tunnels] .i2ptunnel.I2PTunnelClientBase: Unable to connect to the router at 127.0.0.1:7654 and build tunnels for the client, retrying in 20 seconds
10/1/13 12:44:43 AM ERROR [rtup tunnels] eaming.I2PSocketManagerFactory: Error creating session for socket manager

net.i2p.client.I2PSessionException: No manager yet
at net.i2p.router.client.ClientManagerFacadeImpl?.connect(ClientManagerFacadeImpl?.java:254)
at net.i2p.client.I2PSessionImpl.connect(I2PSessionImpl.java:438)
at net.i2p.client.streaming.I2PSocketManagerFactory.createManager(I2PSocketManagerFactory.java:221)
at net.i2p.client.streaming.I2PSocketManagerFactory.createManager(I2PSocketManagerFactory.java:143)
at net.i2p.client.streaming.I2PSocketManagerFactory.createManager(I2PSocketManagerFactory.java:87)
at net.i2p.i2ptunnel.I2PTunnelClientBase.buildSocketManager(I2PTunnelClientBase.java:415)
at net.i2p.i2ptunnel.I2PTunnelClientBase.buildSocketManager(I2PTunnelClientBase.java:370)
at net.i2p.i2ptunnel.I2PTunnelClientBase.getSocketManager(I2PTunnelClientBase.java:332)
at net.i2p.i2ptunnel.I2PTunnelClientBase.getSocketManager(I2PTunnelClientBase.java:290)
at net.i2p.i2ptunnel.I2PTunnelClientBase.verifySocketManager(I2PTunnelClientBase.java:272)
at net.i2p.i2ptunnel.I2PTunnelClientBase.<init>(I2PTunnelClientBase.java:200)
at net.i2p.i2ptunnel.I2PTunnelClientBase.<init>(I2PTunnelClientBase.java:147)
at net.i2p.i2ptunnel.I2PTunnelHTTPClientBase.<init>(I2PTunnelHTTPClientBase.java:98)
at net.i2p.i2ptunnel.I2PTunnelHTTPClient.<init>(I2PTunnelHTTPClient.java:205)
at net.i2p.i2ptunnel.I2PTunnel.runHttpClient(I2PTunnel.java:792)
at net.i2p.i2ptunnel.TunnelController?.startHttpClient(TunnelController?.java:228)
at net.i2p.i2ptunnel.TunnelController?.doStartTunnel(TunnelController?.java:188)
at net.i2p.i2ptunnel.TunnelController?.startTunnel(TunnelController?.java:149)
at net.i2p.i2ptunnel.TunnelControllerGroup?$StartControllers?.run(TunnelControllerGroup?.java:249)
at java.lang.Thread.run(Unknown Source)
at net.i2p.util.I2PThread.run(I2PThread.java:85)

10/1/13 12:42:43 AM CRIT 1/1? net.i2p.router.JobQueueRunner? : Error processing job [Load Router Info] on thread 0: null

java.lang.IllegalStateException?
at net.i2p.data.RouterInfo?.setAddresses(RouterInfo?.java:185)
at net.i2p.router.startup.RebuildRouterInfoJob?.rebuildRouterInfo(RebuildRouterInfoJob?.java:122)
at net.i2p.router.startup.LoadRouterInfoJob?.runJob(LoadRouterInfoJob?.java:48)
at net.i2p.router.JobQueueRunner?.runCurrentJob(JobQueueRunner?.java:134)
at net.i2p.router.JobQueueRunner?.run(JobQueueRunner?.java:75)
at java.lang.Thread.run(Unknown Source)
at net.i2p.util.I2PThread.run(I2PThread.java:85)

10/1/13 12:42:43 AM ↓↓↓ 1 similar message omitted ↓↓↓


10/1/13 12:42:43 AM WARN 1/1? uter.startup.LoadRouterInfoJob?: Rebuilding RouterInfo? with longer key

Subtickets

Change History (4)

comment:1 Changed 6 years ago by str4d

Probably related: #1056

comment:2 Changed 6 years ago by DISABLED

Resolution: not a bug
Status: newclosed

comment:3 Changed 6 years ago by zzz

Resolution: not a bug
Status: closedreopened

comment:4 Changed 6 years ago by zzz

Component: router/wrapperrouter/general
Resolution: duplicate
Status: reopenedclosed

Dup of #1056 and #1060; see #1056 for status

Note: See TracTickets for help on using tickets.