Opened 5 years ago

Closed 5 years ago

#1059 closed defect (worksforme)

"Error in funtion:" i2p-maintainer's ppa broken

Reported by: guest Owned by: killyourtv
Priority: major Milestone: 0.9.9
Component: package/ubuntu Version: 0.9.8
Keywords: error, function, dpkg, ppa Cc: killyourtv@…
Parent Tickets:

Description (last modified by killyourtv)

I2P version: 0.9.8-0
Java version: Sun Microsystems Inc. 1.6.0_27 (OpenJDK Runtime Environment 1.6.0_27-b27)
Wrapper version: 3.5.20
Server version: 7.6.12.v20130726
Servlet version: Jasper JSP 2.1 Engine
Platform: Linux i386 3.2.0-54-generic-pae
Processor: Core i3 or i5/i7 mobile (32nm) (corei)
Jbigi: Locally optimized native BigInteger? library loaded from file
Encoding: UTF-8
Charset: UTF-8

installArchives() failed: Preconfiguring packages ...
Preconfiguring packages ...
Preconfiguring packages ...
Preconfiguring packages ...
(Reading database ... 
(Reading database ... 5%%
(Reading database ... 10%%
(Reading database ... 15%%
(Reading database ... 20%%
(Reading database ... 25%%
(Reading database ... 30%%
(Reading database ... 35%%
(Reading database ... 40%%
(Reading database ... 45%%
(Reading database ... 50%%
(Reading database ... 55%%
(Reading database ... 60%%
(Reading database ... 65%%
(Reading database ... 70%%
(Reading database ... 75%%
(Reading database ... 80%%
(Reading database ... 85%%
(Reading database ... 90%%
(Reading database ... 95%%
(Reading database ... 100%%
(Reading database ... 543074 files and directories currently installed.)
Preparing to replace i2p 0.9.7.1-1p1 (using .../archives/i2p_0.9.8-2p2_all.deb) ...
invoke-rc.d: initscript i2p, action "stop" failed.
dpkg: warning: subprocess old pre-removal script returned error exit status 1
dpkg - trying script from the new package instead ...
invoke-rc.d: initscript i2p, action "stop" failed.
dpkg: error processing /var/cache/apt/archives/i2p_0.9.8-2p2_all.deb (--unpack):
 subprocess new pre-removal script returned error exit status 1
No apport report written because MaxReports is reached already
Aborting upgrade
Errors were encountered while processing:
 /var/cache/apt/archives/i2p_0.9.8-2p2_all.deb
Error in function: 

Subtickets

Change History (8)

comment:1 Changed 5 years ago by guest

  • Component changed from unspecified to package/ubuntu
  • Owner set to killyourtv

comment:2 follow-up: Changed 5 years ago by killyourtv

  • Cc killyourtv@… added
  • Status changed from new to accepted

Thanks for the report. I presume that 0.9.7.1 was working?

I'll try to reproduce and/or fix.

comment:3 in reply to: ↑ 2 Changed 5 years ago by guest

Replying to killyourtv:

Thanks for the report. I presume that 0.9.7.1 was working?

I'll try to reproduce and/or fix.

Thank you for the swift acceptance and reply kytv :) Yes, 0.9.7.1 was working fine and was getting regular updates. Successful in upgrading from 0.9.6 to 0.9.7.1 via Ubuntu ppa. I've reinstalled completely using the JAR file for 0.9.8-0.

comment:4 Changed 5 years ago by guest

  • Resolution set to duplicate
  • Status changed from accepted to closed

comment:5 Changed 5 years ago by killyourtv

  • Resolution duplicate deleted
  • Status changed from closed to reopened

comment:6 Changed 5 years ago by killyourtv

  • Status changed from reopened to accepted

comment:7 Changed 5 years ago by killyourtv

  • Description modified (diff)

comment:8 Changed 5 years ago by killyourtv

  • Resolution set to worksforme
  • Status changed from accepted to closed

I have been unsuccessful in reproducing this and understanding how the errors mentioned could be possible. It was certainly an error on the user's system. Otherwise we would have gotten other reports but there weren't any.

Closing as worksforme.

Note: See TracTickets for help on using tickets.