Opened 5 years ago

Closed 5 years ago

#1078 closed defect (fixed)

Cannot login to Trac with Konqueror or Opera

Reported by: killyourtv Owned by: killyourtv
Priority: minor Milestone:
Component: trac Version:
Keywords: login konqueror opera Cc:
Parent Tickets:

Description

Konqueror 4.11.2
Debian Unstable

Trying to login to trac.i2p2.i2p yields the following:

The requested action is not supported by the KDE program which is implementing the http protocol.

Possible Causes:

This error is very much dependent on the KDE program. The additional information should give you more information than is available to the KDE input/output architecture.
Possible Solutions:

Attempt to find another way to accomplish the same outcome.

Login fails using https://trac.i2p2.de too. Same result with KHTML and Webkit.

Will investigate.

Subtickets

Change History (2)

comment:1 Changed 5 years ago by killyourtv

Also fails in Debian Wheezy.

Debug logs:

kio_http(5991)/kio_http_debug HTTPProtocol::reparseConfiguration:
kio_http(5991)/kio_http_debug HTTPProtocol::setHost: Hostname is now: "trac.i2p2.de" ( "trac.i2p2.de" )
kio_http(5991)/kio_http_debug HTTPProtocol::get: "https://trac.i2p2.de/login"
kio_http(5991)/kio_http_debug HTTPProtocol::maybeSetRequestUrl: "https://trac.i2p2.de/login"
kio_http(5991)/kio_http_debug HTTPProtocol::resetSessionSettings: Window Id = "56623124"
kio_http(5991)/kio_http_debug HTTPProtocol::resetSessionSettings: ssl_was_in_use = ""
kio_http(5991)/kio_http_debug HTTPProtocol::proceedUntilResponseContent:
kio_http(5991)/kio_http_debug HTTPProtocol::proceedUntilResponseHeader:
kio_http(5991)/kio_http_debug HTTPProtocol::sendQuery:
kio_http(5991)/kio_http_debug HTTPProtocol::httpShouldCloseConnection:
kio_http(5991)/kio_http_debug HTTPProtocol::httpOpenConnection:
kio_http(5991)/kio_http_debug HTTPProtocol::httpOpenConnection: Proxy URLs: ("http://127.0.0.1:8118", "socks://127.0.0.1:8118")
kio_http(5991)/kio_http_debug HTTPProtocol::httpOpenConnection: Connecting to proxy: address= "http://127.0.0.1:8118" type= 3
kio_http(5991)/kio_http_debug HTTPProtocol::httpOpenConnection: Tunneling thru proxy: host= "127.0.0.1" port= 8118
kio_http(5991)/kio_http_debug HTTPProtocol::satisfyRequestFromCache:
kio_http(5991)/kio_http_debug HTTPProtocol::cacheFileOpenRead:
kio_http(5991)/kio_http_debug HTTPProtocol::cacheFileClose:
kio_http(5991) HTTPProtocol::sendQuery: ============ Sending Header:
kio_http(5991) HTTPProtocol::sendQuery: "GET /login HTTP/1.1"
kio_http(5991) HTTPProtocol::sendQuery: "Host: trac.i2p2.de"
kio_http(5991) HTTPProtocol::sendQuery: "Connection: keep-alive"
kio_http(5991) HTTPProtocol::sendQuery: "User-Agent: Mozilla/5.0 (X11; Linux x86_64) KHTML/4.8.4 (like Gecko) Konqueror/4.8"
kio_http(5991) HTTPProtocol::sendQuery: "Accept: text/html, text/*;q=0.9, image/jpeg;q=0.9, image/png;q=0.9, image/*;q=0.9, */*;q=0.8"
kio_http(5991) HTTPProtocol::sendQuery: "Accept-Encoding: gzip, deflate, x-gzip, x-deflate"
kio_http(5991) HTTPProtocol::sendQuery: "Accept-Charset: utf-8,*;q=0.5"
kio_http(5991) HTTPProtocol::sendQuery: "Accept-Language: en-US,en;q=0.9"
kio_http(5991)/kio_http_debug HTTPProtocol::sendQuery: sent it!
kio_http(5991)/kio_http_debug HTTPProtocol::readResponseHeader:
kio_http(5991) HTTPProtocol::readResponseHeader: ============ Received Status Response:
kio_http(5991) HTTPProtocol::readResponseHeader: "HTTP/1.1 401 Authorization Required"
kio_http(5991)/kio_http_debug HTTPProtocol::readResponseHeader: wasAuthError= false isAuthError= true sameAuthError= false
kio_http(5991)/kio_http_debug HTTPProtocol::readResponseHeader:  -- full response:
"HTTP/1.1 401 Authorization Required
Date: Thu, 17 Oct 2013 10:10:59 GMT
Server: Apache/2.2.22 (Ubuntu)
WWW-Authenticate: Digest realm="i2p", nonce="pLTMCO3oBAA=395cd2ae3fad8833ce96d428c408ba383dbe40b7", algorithm=MD5, domain="/login/", qop="auth"
Vary: Accept-Encoding
Content-Encoding: gzip
Content-Length: 290
Keep-Alive: timeout=5, max=100
Connection: Keep-Alive
Content-Type: text/html; charset=iso-8859-1"
kio_http(5991)/kio_http_debug HTTPProtocol::readResponseHeader: Content-type: "text/html"
kio_http(5991)/kio_http_debug HTTPProtocol::readResponseHeader: Encoding-type: "charset" = "iso-8859-1"
kio_http(5991)/kio_http_debug HTTPProtocol::handleAuthenticationHeader: Trying authentication scheme: "Digest"
kio_http(5991)/kio_http_debug HTTPProtocol::handleAuthenticationHeader: isError= true needCredentials= true forceKeepAlive= false forceDisconnect= false
kio_http(5991)/kio_http_debug HTTPProtocol::httpClose: keepAlive = true
kio_http(5991)/kio_http_debug HTTPProtocol::cacheFileClose:
kio_http(5991)/kio_http_debug HTTPProtocol::httpClose: keep alive ( 5 )
kio_http(5991)/kio_http_debug HTTPProtocol::readBody: "290" bytes left.
kio_http(5991)/kio_http_debug HTTPProtocol::cacheFileClose:
kio_http(5991)/kio_http_debug HTTPProtocol::special:
kio_http(5991)/kio_http_debug HTTPProtocol::httpCloseConnection:

Not sure yet if it's a KDE or Debian bug. I don't know if there's anything that 'we' can do to work around this.

comment:2 Changed 5 years ago by killyourtv

  • Keywords opera added
  • Resolution set to fixed
  • Status changed from new to closed
  • Summary changed from Cannot login to Trac with Konqueror to Cannot login to Trac with Konqueror or Opera

After a bit of testing:

BrowserStatus
Konqueror (in Debian and openSuse) failed
Opera failed
IE success
Firefox success
Chromium success
Epiphany success

After setting up Trac in a VM I found that Opera & Konqueror worked with tracd. Further experimentation in the VM lead to the discovery that disabling the setting AuthDigestDomain allowed both Opera and Konqueror to be able to login successfully. Also, none of the other browsers stopped working so I think this has been resolved.

Last edited 5 years ago by killyourtv (previous) (diff)
Note: See TracTickets for help on using tickets.