Opened 6 years ago

Closed 15 months ago

#1086 closed defect (no response)

does not opening any .i2p sites

Reported by: guest Owned by:
Priority: minor Milestone:
Component: router/general Version: 0.9.8.1
Keywords: unicode firewall Cc:
Parent Tickets:

Description (last modified by zzz)

Network: OK
Local Destinations
Client shared clients Ready
browser proxy 127.0.0.1:4444

sorry for my english

Logs:

Critical Logs

No log messages
Router Logs (configure)

File location: C:\ProgramData?\Application Data\i2p\logs\log-router-1.txt

25.10.13 17:11:08 WARN [Addressbook ] .naming.BlockfileNamingService?: The hosts database was not closed cleanly or is still open by another process

Service (Wrapper) Logs

File location: C:\Users\xxxxx\AppData?\Roaming\i2p\wrapper.log

2013/10/25 16:58:54 | Error writing to ping file 2013/10/25 16:59:50 | java.io.FileNotFoundException: C:\ProgramData\Application Data\i2p\router.ping (�������� � �������)
2013/10/25 16:58:54 |   at java.io.FileOutputStream.open(Native Method)
2013/10/25 16:58:54 | 	at java.io.FileOutputStream.<init>(Unknown Source)
2013/10/25 16:58:54 | 	at net.i2p.util.SecureFileOutputStream.<init>(SecureFileOutputStream.java:41)
2013/10/25 16:58:54 | 	at net.i2p.router.tasks.MarkLiveliness.ping(MarkLiveliness.java:45)
2013/10/25 16:58:54 | 	at net.i2p.router.tasks.MarkLiveliness.timeReached(MarkLiveliness.java:37)
2013/10/25 16:58:54 | 	at net.i2p.util.SimpleScheduler$RunnableEvent.run(SimpleScheduler.java:168)
2013/10/25 16:58:54 | 	at net.i2p.util.SimpleScheduler$PeriodicRunnableEvent.run(SimpleScheduler.java:201)
2013/10/25 16:58:54 | 	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
2013/10/25 16:58:54 | 	at java.util.concurrent.FutureTask.runAndReset(Unknown Source)
2013/10/25 16:58:54 | 	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(Unknown Source)
2013/10/25 16:58:54 | 	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknown Source)
2013/10/25 16:58:54 | 	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
2013/10/25 16:58:54 | 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
2013/10/25 16:58:54 | 	at java.lang.Thread.run(Unknown Source)

... repeats every minute ...

2013/10/25 17:11:03 | --> Wrapper Started as Console
2013/10/25 17:11:03 | Java Service Wrapper Community Edition 32-bit 3.5.19
2013/10/25 17:11:03 |   Copyright (C) 1999-2013 Tanuki Software, Ltd. All Rights Reserved.
2013/10/25 17:11:03 |     http://wrapper.tanukisoftware.com
2013/10/25 17:11:03 | 
2013/10/25 17:11:04 | Launching a JVM...
2013/10/25 17:11:04 | WrapperManager: Initializing...
2013/10/25 17:11:04 | Starting I2P 0.9.8.1-0
2013/10/25 17:11:04 | WARN: Old router was not shut down gracefully, deleting router.ping
2013/10/25 17:11:04 | INFO: Native CPUID library jcpuid-x86-windows loaded from file
2013/10/25 17:11:04 | INFO: Locally optimized native BigInteger library loaded from file
2013/10/25 17:11:05 | INFO: Jetty 7.6.12.v20130726 logging to I2P logs using class org.eclipse.jetty.server.Server
2013/10/25 17:11:08 | 2013-10-25 13:11:08.145:INFO:oejs.Server:jetty-7.6.12.v20130726
2013/10/25 17:11:08 | Adding E:\Program Files (x86)\i2p\lib/jetty-util.jar to classpath for susimail
2013/10/25 17:11:35 | 2013-10-25 13:11:35.726:INFO:oejs.Server:jetty-7.6.12.v20130726

Subtickets

Change History (11)

comment:1 Changed 6 years ago by zzz

  • Component changed from unspecified to router/general
  • Description modified (diff)

Very strange. I have never seen this before.

The ping file problem by itself is not important (we don't need a ping file). But it may indicate a permissions problem with the file C:\ProgramData??\Application Data\i2p\router.ping or the directory.

It is strange that the wrapper logs are in C:\Users\xxxxx\AppData?\Roaming\i2p\ but the ping file and router logs are in C:\ProgramData??\Application Data\i2p\ , they should normally be in the same place.

The second problem is that we log the ping file problem every minute. I'll fix it so we only log it once.

comment:2 Changed 6 years ago by zzz

  • Description modified (diff)

comment:3 Changed 6 years ago by zzz

  • Description modified (diff)

comment:4 Changed 6 years ago by zzz

Also, check to make sure you do not have I2P running twice, once as a service and once as your user.

comment:5 Changed 6 years ago by zzz

Also, the reason cause in your native language / character set may provide a clue. In the log you pasted, it appears as question marks (�������� � �������) here.

comment:6 follow-up: Changed 6 years ago by zzz

Only log message once fixed in f4726aaec0e0b824c2787ac2705f970bbe22c240 0.9.8.1-11

comment:7 in reply to: ↑ 6 Changed 6 years ago by guest

i2p was installed with standart settings and i didn`t move files manually...
windows was installed with standart settings too, i don`t know why charset error exists
i2p doesn`t running twise or more
did not anderstand about Only log message once fixed in f4726aaec0e0b824c2787ac2705f970bbe22c240 0.9.8.1-11

comment:8 follow-up: Changed 6 years ago by zzz

can you look on your log page and tell us what the question marks say? Assuming they are not question marks on your log page...

comment:9 in reply to: ↑ 8 Changed 6 years ago by guest

no,question marks were in logs page, i didn`t change log text(and they are in logs page now)

i reinstall all, included Шindows and now i2p works, but only while firewall(comodo) disable.
if firewall work - WARN - Firewalled with Inbound TCP Enabled
(all settings have default values and all,what hips/firewall asked about i2psvc.exe and java.exe was allowed..

Last edited 6 years ago by guest (previous) (diff)

comment:10 Changed 4 years ago by str4d

  • Keywords unicode firewall added
  • Milestone 0.9.9 deleted

comment:11 Changed 15 months ago by echelon

  • Resolution set to no response
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.