Opened 6 years ago

Closed 5 years ago

#1091 closed defect (worksforme)

server tunnel limits work partly not

Reported by: Eche|on Owned by: zzz
Priority: minor Milestone: 0.9.9
Component: streaming Version: 0.9.8.1
Keywords: limits Cc:
Parent Tickets: Sensitive: no

Description

Moin!

I do have a limit of e.g. 3000 accesses per host and day on false.i2p.
Since a few days I do run 0.9.8.1-9 and I do know some code did change shortly.
Now I still get some error messages like "refusing connection since peer is thottled by peer limit … per day".
BUT if I grep daily squid log, I do see accesses by one peer ID with ~8.000 accesses a day. And with this far above the 3000 allowed.
Something seems to be buggy in this code, as squid is already after that tunnel limit.
I do see this effect for the last 2 days at least.

Subtickets

Change History (4)

comment:1 Changed 6 years ago by killyourtv

Component: router/transportapps/i2ptunnel

comment:2 Changed 6 years ago by zzz

Component: apps/i2ptunnelstreaming

The work on conn limits started in -10.

Only ideas:

  • router restart will start the counters again of course
  • tunnel restart, ditto
  • day boundary - 3000 + 3000 = 6000

No idea how to get to 8000.

will check some logs here.

comment:3 Changed 6 years ago by killyourtv

Lost in the spam clean-up:

Moin
Router was not restarted in 3 days, same with tunnel.
Sure, day boundary, but squid log is rotated daily at ~5 am. Would need a
good timing to get twice the 24h limit in these frames.
I keep a eye on it.

echelon

comment:4 Changed 5 years ago by zzz

Resolution: worksforme
Status: newclosed

Don't know how to reproduce this, code looks fine, closing for now.

Note that day boundary is now at a random time after restart, to prevent attackers from correlating blocking/unblocking with router start time.

Note: See TracTickets for help on using tickets.