Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1093 closed defect (fixed)

Wrong link for "Start the torrent"

Reported by: necrotek Owned by: zzz
Priority: major Milestone: 0.9.9
Component: apps/i2psnark Version: 0.9.8.1
Keywords: Cc:
Parent Tickets:

Description

"Start the torrent" button which is used to start specific torrent for downloading forms the link in a wrong way. Instead of
http://127.0.0.1:7657/i2psnark/?action=Start_<trimmed> links it uses​http://i2psnark/?action=Start_<trimmed>. The only way to start the torrent is to manually fix the link or use the button to start all torrents.

(filed by killyourtv on based on http://pastethis.i2p/show/6081/)

Subtickets

Change History (5)

comment:1 in reply to: ↑ description Changed 5 years ago by killyourtv

  • Status changed from new to infoneeded_new

Replying to necrotek:

"Start the torrent" button which is used to start specific torrent for downloading forms the link in a wrong way. Instead of
http://127.0.0.1:7657/i2psnark/?action=Start_<trimmed> links it uses​http://i2psnark/?action=Start_<trimmed>. The only way to start the torrent is to manually fix the link or use the button to start all torrents.

(filed by killyourtv on based on http://pastethis.i2p/show/6081/)

Which browser are you seeing this in? I don't have this problem in Firefox.

comment:2 Changed 5 years ago by zzz

  • Status changed from infoneeded_new to new

The buttons are POST for most browsers but GET for Opera and some "text mode" browsers. The text mode GET link is probably broken. Bug confirmed using elinks. Looks like there is an extra / at the beginning ("i2psnark/...") which the browser is interpreting as http://i2psnark/...

comment:3 Changed 5 years ago by zzz

  • Status changed from new to accepted

comment:4 Changed 5 years ago by zzz

  • Priority changed from minor to major
  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed in f52aec46cae0f3ebcc2ec98928cd8d09e4cfad28 0.9.8.1-16

Thanks for the report.

Workaround is to use a graphical browser that's not Opera.

comment:5 Changed 5 years ago by necrotek

Oh, you're right, I didn't think of mentioning my browser. Indeed, it was Opera.
Anyway, thank you for your fix.

Note: See TracTickets for help on using tickets.