Opened 6 years ago

Closed 4 years ago

#1127 closed defect (worksforme)

syndie: java.sql.SQLInvalidAuthorizationSpecException: invalid authorization specification - not found: USER

Reported by: Eche|on Owned by:
Priority: major Milestone:
Component: apps/syndie Version: 0.9.8.1
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

Moin

I did a upgrade of my syndie CLI version from old 1.103 up to latest mtn rev d7cd3cc1b9d676c250918b583c4da41d48ea70bc (14.11.2013).
I did restart and it seemed to redo the DB, but on another restart I get:

java -jar syndie-cli.jar /opt/syndie
Warning, interactive CLI will interfere with bulkimport if running httpserv
Run with —nostdin to disable intactive CLI

  • Next command: Error trying to login

java.sql.SQLInvalidAuthorizationSpecException: invalid authorization specification - not found: USER

at org.hsqldb.jdbc.JDBCUtil.sqlException(Unknown Source)
at org.hsqldb.jdbc.JDBCUtil.sqlException(Unknown Source)
at org.hsqldb.jdbc.JDBCConnection.<init>(Unknown Source)
at org.hsqldb.jdbc.JDBCDriver.getConnection(Unknown Source)
at org.hsqldb.jdbc.JDBCDriver.connect(Unknown Source)
at java.sql.DriverManager?.getConnection(DriverManager?.java:571)
at java.sql.DriverManager?.getConnection(DriverManager?.java:215)
at syndie.db.DBClient.connect(DBClient.java:249)
at syndie.db.DBClient.connect(DBClient.java:396)
at syndie.db.TextEngine?.processLogin(TextEngine?.java:425)
at syndie.db.TextEngine?.access$100(TextEngine?.java:33)
at syndie.db.TextEngine?$StartMenu?.processCommands(TextEngine?.java:1133)
at syndie.db.TextEngine?.processMenu(TextEngine?.java:599)
at syndie.db.TextEngine?.doRunStep(TextEngine?.java:179)
at syndie.db.TextEngine?.runStep(TextEngine?.java:159)
at syndie.db.TextEngine?.run(TextEngine?.java:148)
at syndie.db.TextUI.run(TextUI.java:295)
at syndie.db.TextUI.main(TextUI.java:236)

Caused by: org.hsqldb.HsqlException?: invalid authorization specification - not found: USER

at org.hsqldb.error.Error.error(Unknown Source)
at org.hsqldb.error.Error.error(Unknown Source)
at org.hsqldb.rights.UserManager?.get(Unknown Source)
at org.hsqldb.rights.UserManager?.getUser(Unknown Source)
at org.hsqldb.Database.connect(Unknown Source)
at org.hsqldb.DatabaseManager?.newSession(Unknown Source)
… 16 more

  • Command execution complete.
  • Status: 0
  • Location:
  • Next command: * Next command:

Subtickets

Change History (6)

comment:1 Changed 6 years ago by zzz

Component: otherapps/syndie

There was some upper/lower case confusion along the way.

Try entering the command login —login USER —pass PASS with all 4 combinations of USER/user PASS/pass

If it works, add the args to the login command in the file ~/.syndie/scripts/startup .

comment:2 Changed 6 years ago by Eche|on

Moin

tested all 4 combinations - did not work. Always same error as above.
Is it really "USER" as username and "PASS" as password?
I tried: USER-PASS USER-pass user-PASS user-pass

comment:3 Changed 6 years ago by zzz

I can't reproduce it here.

When I run the CLI and logout then login —login foo —pass bar, I get "invalid authorization specification" but without the "not found: foo".

login —login USER —pass PASS works.

The database initialization in syndie adds USER/PASS and changes the system SA/"" to SA/{random string}

This was not helpful:
http://stackoverflow.com/questions/8828771/hsqldb-bypass-authentication-reset-forgotten-user-and-password

In my ~/.syndie/db/syndie.script file I can see the lines:

CREATE USER SA PASSWORD DIGEST '6e2b6de3d2d345ff6057a3e8122ef33f'
CREATE USER USER PASSWORD DIGEST '7a95bf926a0333f57705aeac07a362a2'

Now maybe the second one is the hash for "PASS", dunno if it's salted.

Maybe the script file could be hacked and then restored from.

But I'm stuck. I don't know how it happened or how to recover.

comment:4 Changed 5 years ago by str4d

Keywords: syndie login removed
Milestone: 0.9.9

comment:5 Changed 4 years ago by str4d

Status: newopen

comment:6 Changed 4 years ago by zzz

Resolution: worksforme
Status: openclosed
Note: See TracTickets for help on using tickets.