Opened 6 years ago

Closed 5 years ago

#1145 closed defect (fixed)

Setting Hashcash Certificate When Tunnel is off Throws Exception

Reported by: psi Owned by:
Priority: major Milestone: 0.9.10
Component: apps/i2ptunnel Version: 0.9.9
Keywords: hashcash Cc:
Parent Tickets: Sensitive: no

Description

To reproduce:

1) stop tunnel
2) change certificate type from "none" to "hashcash"
3) click modify
4) goes back to i2ptunnel main screen with no error message
5) stack trace in /logs

12/8/13 XX:XX:XX AM CRIT [onsole Jetty] et.i2p.i2ptunnel.web.IndexBean?: Error processing Modify

java.lang.IllegalStateException?
at net.i2p.data.KeysAndCert?.setCertificate(KeysAndCert?.java:48)
at net.i2p.data.PrivateKeyFile?.setCertType(PrivateKeyFile?.java:201)
at net.i2p.data.PrivateKeyFile?.setHashCashCert(PrivateKeyFile?.java:207)
at net.i2p.i2ptunnel.web.IndexBean?.modifyDestination(IndexBean?.java:995)
at net.i2p.i2ptunnel.web.IndexBean?.processAction(IndexBean?.java:218)
at net.i2p.i2ptunnel.web.IndexBean?.getMessages(IndexBean?.java:405)
at net.i2p.i2ptunnel.jsp.index_jsp._jspService(index_jsp.java:99)
at org.apache.jasper.runtime.HttpJspBase?.service(HttpJspBase?.java:70)
at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:723)
at org.eclipse.jetty.servlet.ServletHolder?.handle(ServletHolder?.java:654)
at org.eclipse.jetty.servlet.ServletHandler?.doHandle(ServletHandler?.java:445)
at org.eclipse.jetty.server.handler.ScopedHandler?.handle(ScopedHandler?.java:137)
at org.eclipse.jetty.security.SecurityHandler?.handle(SecurityHandler?.java:556)
at org.eclipse.jetty.server.session.SessionHandler?.doHandle(SessionHandler?.java:227)
at org.eclipse.jetty.server.handler.ContextHandler?.doHandle(ContextHandler?.java:1044)
at org.eclipse.jetty.servlet.ServletHandler?.doScope(ServletHandler?.java:372)
at org.eclipse.jetty.server.session.SessionHandler?.doScope(SessionHandler?.java:189)
at org.eclipse.jetty.server.handler.ContextHandler?.doScope(ContextHandler?.java:978)
at org.eclipse.jetty.server.handler.ScopedHandler?.handle(ScopedHandler?.java:135)
at org.eclipse.jetty.server.handler.ContextHandlerCollection?.handle(ContextHandlerCollection?.java:255)
at org.eclipse.jetty.server.handler.HandlerCollection?.handle(HandlerCollection?.java:154)
at org.eclipse.jetty.server.handler.HandlerWrapper?.handle(HandlerWrapper?.java:116)
at org.eclipse.jetty.server.Server.handle(Server.java:369)
at org.eclipse.jetty.server.AbstractHttpConnection?.handleRequest(AbstractHttpConnection?.java:486)
at org.eclipse.jetty.server.AbstractHttpConnection?.content(AbstractHttpConnection?.java:944)
at org.eclipse.jetty.server.AbstractHttpConnection?$RequestHandler?.content(AbstractHttpConnection?.java:1005)
at org.eclipse.jetty.http.HttpParser?.parseNext(HttpParser?.java:865)
at org.eclipse.jetty.http.HttpParser?.parseAvailable(HttpParser?.java:240)
at org.eclipse.jetty.server.AsyncHttpConnection?.handle(AsyncHttpConnection?.java:82)
at org.eclipse.jetty.io.nio.SelectChannelEndPoint?.handle(SelectChannelEndPoint?.java:668)
at org.eclipse.jetty.io.nio.SelectChannelEndPoint?$1.run(SelectChannelEndPoint?.java:52)
at java.util.concurrent.ThreadPoolExecutor?.runWorker(ThreadPoolExecutor?.java:1142)
at java.util.concurrent.ThreadPoolExecutor?$Worker.run(ThreadPoolExecutor?.java:617)
at java.lang.Thread.run(Thread.java:724)

Subtickets

Change History (3)

comment:1 Changed 6 years ago by zzz

Caused by change in 0.9.9 making a Destination immutable.

Also affects PrivateKeyFile?. Both will need to be fixed. You must create a new Destination, you can no longer modify the cert in a Destination.

http://zzz.i2p/topics/152?page=1#p7449

comment:2 Changed 6 years ago by zzz

Status: newtesting

Fixed in i2p.i2p.zzz.test2 ff31f691fbbd29e6d713863cc86a7e52a976fccb to be propped for 0.9.10

comment:3 Changed 5 years ago by zzz

Resolution: fixed
Status: testingclosed
Note: See TracTickets for help on using tickets.