Opened 5 years ago

Closed 5 years ago

#1178 closed defect (not a bug)

java.net.SocketException: No buffer space available

Reported by: echelon Owned by:
Priority: minor Milestone:
Component: apps/i2ptunnel Version: 0.9.9
Keywords: Cc:
Parent Tickets:

Description

HI

1/21/14 9:15:38 PM ERROR [7.0.0.1:7658] .i2ptunnel.I2PTunnelHTTPServer: Error connecting to HTTP server /127.0.0.1:7658

java.net.SocketException?: No buffer space available
at java.net.PlainSocketImpl?.socketConnect(Native Method)
at java.net.AbstractPlainSocketImpl?.doConnect(AbstractPlainSocketImpl?.java:339)
at java.net.AbstractPlainSocketImpl?.connectToAddress(AbstractPlainSocketImpl?.java:200)
at java.net.AbstractPlainSocketImpl?.connect(AbstractPlainSocketImpl?.java:182)
at java.net.SocksSocketImpl?.connect(SocksSocketImpl?.java:392)
at java.net.Socket.connect(Socket.java:579)
at java.net.Socket.connect(Socket.java:528)
at java.net.Socket.<init>(Socket.java:425)
at java.net.Socket.<init>(Socket.java:241)
at net.i2p.i2ptunnel.I2PTunnelServer.getSocket(I2PTunnelServer.java:587)
at net.i2p.i2ptunnel.I2PTunnelServer.getSocket(I2PTunnelServer.java:561)
at net.i2p.i2ptunnel.I2PTunnelHTTPServer.blockingHandle(I2PTunnelHTTPServer.java:249)
at net.i2p.i2ptunnel.I2PTunnelServer$Handler.run(I2PTunnelServer.java:508)
at java.util.concurrent.ThreadPoolExecutor?.runWorker(ThreadPoolExecutor?.java:1145)
at java.util.concurrent.ThreadPoolExecutor?$Worker.run(ThreadPoolExecutor?.java:615)
at java.lang.Thread.run(Thread.java:744)

I2P version: 0.9.9-0-1deb8u1
Java version: Oracle Corporation 1.7.0_51 (Java(TM) SE Runtime Environment 1.7.0_51-b13)
Wrapper version: 3.5.3
Server version: 7.6.13.v20130916
Servlet version: Jasper JSP 2.1 Engine
Platform: Linux amd64 2.6.32-042stab084.14
Processor: Core 2 (Conroe) (core2)
Jbigi: Locally optimized native BigInteger? library loaded from file
Encoding: ANSI_X3.4-1968
Charset: US-ASCII

java heap still 128MB

Subtickets

Change History (3)

comment:1 Changed 5 years ago by zzz

  • Milestone 0.9.11 deleted

googling uncovers only a few possibilities:

  • Windows 7 issue (but you're on linux)
  • leaking sockets in our code
  • running out of ephemeral ports
  • some other OS resource exhaustion

Was this on a very busy server?

no good ideas atm

comment:2 Changed 5 years ago by echelon

Moin

yeah, it is on a loaded linux VM. To many virtual machines on a host using too much ressources is my guess.

echelon

comment:3 Changed 5 years ago by zzz

  • Resolution set to not a bug
  • Status changed from new to closed

ok, let's close this for now

Note: See TracTickets for help on using tickets.