Opened 9 years ago

Closed 8 years ago

#120 closed defect (fixed)

UPnP parser exeption, I always get it

Reported by: anonymous Owned by: zzz
Priority: minor Milestone: 0.8.3
Component: router/transport Version: 0.8
Keywords: Cc:
Parent Tickets:

Description

itte fügen Sie folgende Informationen dem Bug-Report hinzu:

I2P version: 0.8-0
Java version: Sun Microsystems Inc. 1.6.0_18 (Java(TM) SE Runtime Environment 1.6.0_18-b07)
Platform: SunOS x86 5.11
Processor: uninitialized (unrecognized)
Jbigi: Native BigInteger? library jbigi not loaded, reason: 'Dont know jbigi library name for os type 'SunOS - using pure java
Encoding: UTF-8
Berichte der Kritischen Ereignisse

No log messages
Router Berichte (ändern)
Ort der Datei: /home/user/.i2p/logs/log-router-0.txt

  • 11:44:54.909 FEHLER [Thread-14 ] org.cybergarage.util.Debug : org.cybergarage.xml.ParserException?: org.xml.sax.SAXParseException: Content is not allowed in trailing section. at org.cybergarage.xml.parser.JaxpParser?.parse(JaxpParser?.java:121) at org.cybergarage.soap.SOAPRequest.getRootNode(SOAPRequest.java:122) at org.cybergarage.soap.SOAPRequest.getEnvelopeNode(SOAPRequest.java:142) at org.cybergarage.upnp.event.NotifyRequest?.getPropertyList(NotifyRequest?.java:176) at org.cybergarage.upnp.ControlPoint?.httpRequestRecieved(ControlPoint?.java:546) at org.cybergarage.http.HTTPServer.performRequestListener(HTTPServer.java:157) at org.cybergarage.http.HTTPServerThread.run(HTTPServerThread.java:49) Caused by: org.xml.sax.SAXParseException: Content is not allowed in trailing section. at com.sun.org.apache.xerces.internal.parsers.DOMParser.parse(DOMParser.java:249) at com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderImpl?.parse(DocumentBuilderImpl?.java:284) at org.cybergarage.xml.parser.JaxpParser?.parse(JaxpParser?.java:106) ... 6 more

Subtickets

Change History (2)

comment:1 Changed 9 years ago by zzz

  • Component changed from router/general to router/transport
  • Owner set to zzz
  • Status changed from new to assigned
  • Summary changed from parser exeption, I always get it to UPnP parser exeption, I always get it

It's caused by UPnP and is harmless, need to hide it from the logs, or figure out how to make the parser not complain, but last time I looked at it I couldn't figure out how.

comment:2 Changed 8 years ago by zzz

  • Milestone set to 0.8.3
  • Resolution set to fixed
  • Status changed from assigned to closed
  • Version set to 0.8

All UPnP errors changed to warnings in 0.8.3

Note: See TracTickets for help on using tickets.