Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1211 closed defect (duplicate)

Orchid: deadlock

Reported by: killyourtv Owned by:
Priority: minor Milestone:
Component: apps/plugins Version: 0.9.11
Keywords: Cc:
Parent Tickets:

Description

I2P version: 0.9.11-3-deb1
Java version: Oracle Corporation 1.7.0_51 (OpenJDK Runtime Environment 1.7.0_51-b31)
Wrapper version: 3.5.24
Server version: 7.6.14.v20131031
Servlet version: Jasper JSP 2.1 Engine
Platform: Linux amd64 3.12-1-amd64

I don't know when orchid stopped responding. On this box I go out directly via Tor (installed from a Debian pkg). I went to access the status page and the request hanged.

I stopped Orchid and the button changed from Stop to Start, signifying that it had stopped but the Orchid links are still in the router console, both in the side bar and at http://127.0.0.1:7657/home. I tried to restart Orchid from the clients page and that request is hung.

There is nothing related in the logs.

Subtickets

Change History (3)

comment:1 Changed 5 years ago by zzz

If it happens again take a thread dump. May be a deadlock as reported in #1207.

comment:2 Changed 5 years ago by killyourtv

  • Resolution set to duplicate
  • Status changed from new to closed

I did the thread dump at the time but didn't notice this one little line.

2014/02/18 18:22:13 | Found 1 deadlock

Ugh.

More of the dump at http://pastethis.i2p/show/ew1lLhI4kEAPvFsn1xhI/

(closing as a duplicate of #1207)

comment:3 Changed 5 years ago by killyourtv

  • Summary changed from Orchid: No response to Orchid: deadlock
Note: See TracTickets for help on using tickets.