Opened 6 years ago

Closed 6 years ago

#1219 closed defect (fixed)

Android requires jetty and commons-logging jars

Reported by: zzz Owned by: str4d
Priority: minor Milestone: 0.9.12
Component: apps/android Version: 0.9.11
Keywords: Cc: nextloop
Parent Tickets: Sensitive: no

Description

See #1214 comment 4. Shouldn't be necessary.

Subtickets

Change History (6)

comment:1 Changed 6 years ago by str4d

The problem is that the buildAddressbook target requires Jetty, because the addressbook is nominally built as a .war. zzz made a separate buildI2PTunnelJar target in rev aa2bbd9530c394c9ec9061de36cd000f33682dfb which works because I2PTunnel has a .jar and .war.

I can add a buildAddressbookJar target if that is sufficient. I think it should be?

comment:2 Changed 6 years ago by nextloop

Cc: nextloop added

comment:3 Changed 6 years ago by zzz

Sounds reasonable. There's a little hackery in routerjars/custom_rules.xml to convert the war to a jar and take out the servlet; by building a proper jar with only what's required over on the i2p.i2p side, that should fix it.

comment:4 Changed 6 years ago by zzz

Owner: changed from zzz to str4d
Status: newassigned

comment:5 Changed 6 years ago by str4d

Status: assignedtesting

Fixes to addressbook.jar building and a buildAddressbookJar target pushed to i2p.i2p in rev a18d0ae73f765c4306cf0f5379e8eb64951d29ae. Fixes to routerjars/custom_rules.xml pushed to i2p.android.base.fragments in rev 7c6e0ef33be62656657dd48e22855fcc6854d453 (by accident, but it will get back into upstream for 0.9.12, which is when I am targeting my branch for propping).

comment:6 Changed 6 years ago by str4d

Resolution: fixed
Status: testingclosed

i2p.android.base.fragments has been propped upstream.

Note: See TracTickets for help on using tickets.