Opened 5 years ago

Closed 3 years ago

Last modified 2 years ago

#1220 closed defect (fixed)

Orchid: Excess circuit creation looking for key certificates

Reported by: zzz Owned by:
Priority: minor Milestone: 0.9.27
Component: apps/plugins Version: 0.9.11
Keywords: Orchid Cc:
Parent Tickets:

Description

Possibly related: #1213

241 circuits created in 23 minutes

All trying to download the same thing:

xx:xx:44.375 DEBUG [33-thread-59] rchid.circuits.CircuitExtender: Creating 'fast' to Router[PiratenParteiNRW (a.b.c.d:eee)]
xx:xx:45.114 DEBUG [33-thread-59] aph.orchid.circuits.StreamImpl: Closing stream [Stream stream_id=37245 circuit=  Circuit (Directory) id=51932 s
tate=Open [Dirty 0s] [|PiratenParteiNRW|] target=[Directory]]
xx:xx:45.114 DEBUG [33-thread-59] raph.orchid.circuits.CircuitIO: Closing circuit   Circuit (Directory) id=51932 state=Open [Dirty 0s] [|PiratenP
arteiNRW|]
xx:xx:45.114 WARN  [33-thread-59] wnloader.DirectoryDownloadTask: Failed to download key certificates: Request /tor/keys/fp-sk/xxxxxxxxxxxxxxxxxx
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx to directory (none) returned error code: 404 Not found

Subtickets

Change History (4)

comment:1 Changed 4 years ago by str4d

  • Keywords Orchid added

comment:2 Changed 3 years ago by str4d

  • Status changed from new to open

comment:3 Changed 3 years ago by zzz

  • Milestone set to 0.9.27
  • Resolution set to fixed
  • Status changed from open to closed

This is caused by trying to verify a cached consensus that is too old. Fixed in 1.2.2-0.1 to be released today. See http://zzz.i2p/topics/2031 posts 16, 18, and 20 for details.

See also:

https://github.com/subgraph/Orchid/issues/24
https://github.com/bitcoinj/bitcoinj/issues/1064

There may be other cases that trigger this (and see also #1213) but let's close this ticket for now.

comment:4 Changed 2 years ago by zzz

This may not be a complete fix, see #1937

Note: See TracTickets for help on using tickets.