Opened 5 years ago

Closed 5 years ago

#1224 closed defect (fixed)

FloodfillNetworkDatabaseFacade: Invalid leaseSet signature!

Reported by: Soap Owned by: zzz
Priority: minor Milestone: 0.9.12
Component: router/netdb Version: 0.9.11
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

I2P version: 0.9.11-0
Java version: Oracle Corporation 1.7.0_17 (Java™ SE Runtime Environment 1.7.0_17-b02)
Wrapper version: 3.5.17
Server version: 7.6.14.v20131031
Servlet version: Jasper JSP 2.1 Engine
Platform: Windows 7 x86 6.1
Processor: uninitialized (core2)
Jbigi: Locally optimized native BigInteger? library loaded from file
Encoding: Cp1252
Charset: windows-1252

ERROR [JobQueue 1/1] FloodfillNetworkDatabaseFacade: Invalid leaseSet signature! leaseSet = [LeaseSet:
Destination: [Destination:
Hash: #...XYZ=
Certificate: [Certificate: type: Null certificate null payload]
PublicKey: [PublicKey: size: 256]
SigningPublicKey: [SigningPublicKey DSA_SHA1: size: 128]]
EncryptionKey: [PublicKey: size: 256]
SigningKey: [SigningPublicKey DSA_SHA1: size: 128]
Signature: [Signature DSA_SHA1: size: 40]
Leases: #3
[Lease:
End Date: GMT 2014
Gateway: [Hash: iill...ABC=]
TunnelId: #]
[Lease:
End Date: GMT 2014
Gateway: [Hash: -xYHk...RPQ=]
TunnelId: #]
[Lease:
End Date: GMT 2014
Gateway: [Hash: myNz...GTY=]
TunnelId: #]]

Subtickets

Change History (2)

comment:1 Changed 5 years ago by zzz

Component: unspecifiedrouter/netdb
Owner: set to zzz

perhaps an i2pd or i2pcpp bug. probably should be a warn in java router

comment:2 Changed 5 years ago by zzz

Resolution: fixed
Status: newclosed

This was caused by a bug introduced early in 0.9.11-x in SSU introducer code that caused the Hash cache to be corrupted. It could affect the local router or send bad leasesets to other routers. Fixed late in the 0.9.11-x cycle in 4409528adba1de88d2de05011754c4c84932f5e7

Note: See TracTickets for help on using tickets.