Opened 5 years ago

Closed 5 years ago

#1242 closed defect (duplicate)

I2P-Bote: crashes JVM / i2prouter

Reported by: weebs Owned by:
Priority: major Milestone: 0.9.13
Component: apps/plugins Version: 0.9.12
Keywords: i2pbote Cc:
Parent Tickets:

Description

Once i2pbote plugin is installed and 'SecureMail?' is clicked, jvm crashes. After manually killing i2prouter, i2prouter fails to start using 'i2prouter console'. Once I remove the i2pbote directory from /opt/i2p/.i2p/plugins, i2prouter runs as normal.

Subtickets

Attachments (2)

hs_err_pid21529.log (108.4 KB) - added by weebs 5 years ago.
error log
i2pboteerror.txt (5.3 KB) - added by weebs 5 years ago.
'i2prouter console' dump

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by weebs

error log

Changed 5 years ago by weebs

'i2prouter console' dump

comment:1 Changed 5 years ago by str4d

  • Component changed from unspecified to apps/plugins
  • Keywords i2pbote added
  • Milestone 0.9.13 deleted
  • Summary changed from i2pbote crashes JVM / i2prouter to I2P-Bote: crashes JVM / i2prouter

Probable duplicate of #1241, close this ticket if/when confirmed.

comment:2 Changed 5 years ago by str4d

  • Milestone set to 0.9.13
  • Status changed from new to testing

Updated scrypt to 1.4.0, and the problem disappeared. The only upstream changes were to some comments, and to enable overriding the native library loader. Monitoring for further problems.

comment:3 Changed 5 years ago by str4d

  • Status changed from testing to needs_work

Update that I forgot to post at the time: the problems had not disappeared. See #1241 for further info.

comment:4 Changed 5 years ago by str4d

  • Resolution set to duplicate
  • Status changed from needs_work to closed

This is almost definitely a duplicate of #1241.

Note: See TracTickets for help on using tickets.