Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1247 closed defect (fixed)

Bote + IMAP => OOM

Reported by: killyourtv Owned by: HungryHobo
Priority: major Milestone: 0.9.13
Component: apps/plugins Version:
Keywords: Cc: zab@…
Parent Tickets:

Description

I don't know if this is a known problem, but navigating I2P-Bote with IMAP triggers an OOM.

I don't know (yet) if it's a specific folder causing it or a specific message, but I do have a heap dump that was generated at the time of the OOM in case it's be of use.

The largest retained objects are in i2p.bote.folder.EmailFolder.

(This is with I2P-Bote in trunk, currently rev 586515162c23d6374d92552e7433e47207e52edd)

Subtickets

Attachments (1)

heapdump1.png (57.0 KB) - added by killyourtv 5 years ago.
visualvm

Download all attachments as: .zip

Change History (7)

comment:1 Changed 5 years ago by zab

  • Cc zab@… added

A heap dump is the best/only way to properly debug this. However, you want to make sure there is no sensitive information in the dump. That means you should use a separate instance of the jvm with only Bote in it, and you should use a throwaway Bote identity.

comment:2 Changed 5 years ago by killyourtv

I'll set up a Debian unstable VM (with throwaway IDs) and try reproducing this problem in the virtualized environment.

comment:3 Changed 5 years ago by killyourtv

With current trunk I can still reproduce the OOM in my normal installation.

I have not yet been able to reproduce it in my test virtual machine.

Changed 5 years ago by killyourtv

visualvm

comment:4 Changed 5 years ago by str4d

  • Milestone set to 0.9.13
  • Status changed from new to testing

My suspicion is that i2p.bote.imap.MapperFactory.getMailboxes() was causing this problem; the BoteMailboxes? were not cached, but each one registers a FolderListener? with its underlying EmailFolder?. I believe this caused them to never be GCed. I am not sure why EmailFolder? is the one that shows up as the largest retained objects, there should only ever be four (inbox, outbox, sent and trash).

Please try latest trunk, which caches BoteMailboxes?.

Version 0, edited 5 years ago by str4d (next)

comment:5 Changed 5 years ago by killyourtv

  • Milestone 0.9.13 deleted
  • Resolution set to fixed
  • Status changed from testing to closed

It's been about a week and it looks like the OOMs that I was seeing are gone. :)

comment:6 Changed 5 years ago by killyourtv

  • Milestone set to 0.9.13
Note: See TracTickets for help on using tickets.