Opened 5 years ago

Last modified 18 months ago

#1248 assigned defect

One count tunnels run poorly

Reported by: dg Owned by: zzz
Priority: minor Milestone:
Component: router/general Version: 0.9.12
Keywords: reliability proof-needed Cc:
Parent Tickets: Sensitive: no

Description (last modified by dg)

Tunnels configured to only have 1 count and 3 hops will run poorly. I've observed 'going yellow' in the I2PTunnel sidebar frequently.

The tunnel will have an outbound(?) tunnel that is close to expiry (80 seconds or smaller) and usually no inbound tunnel. It will make many attempts to try build but fail, resulting in no tunnels for the service/connection for a while.

zzz says it could be because of the tunnel dropping requests after too many attempts.

This makes it very hard to use any tunnel with 1 count.

kytv MIGHT have IRC logs of my explanation and zzz's response, he may not. This ticket is from memory so the outbound/inbound may be confused.

Subtickets

Change History (6)

comment:1 Changed 5 years ago by dg

Description: modified (diff)

comment:2 Changed 5 years ago by dg

Apr 03 19:21:26 <@dg> zzz: I have a 1 tunnel 3 hop tunnel. I see it goes 'yellow' a lot. When I view it, it has one inbound tunnel that's VERY close to expiration (70 or fewer seconds) and no outbound tunnels
Apr 03 19:21:34 <@dg> It usually has 2 attempts to build going out
Apr 03 19:21:35 <@dg> this isn't a rare thing at all
Apr 03 19:21:44 <@dg> other tunnels that need one get them pretty quick
Apr 03 19:21:54 <@dg> my 1 tunnel one though? no.
Apr 03 19:21:59 <@dg> has this got any significance?
Apr 03 19:22:20 <@dg> right now, 60 seconds to expire on inbound and no outbound. trying to build 1 inbound and 2 outbound
Apr 03 20:23:48 <@zzz> yeah it's a problem. The build requests / replies use the sole "paired tunnel" which gets overwhelmed and starts dropping stuff
Apr 03 20:23:55 <@zzz> and it all goes to hell
Apr 03 20:24:30 <@dg> so i'm not going crazy

Last edited 5 years ago by dg (previous) (diff)

comment:3 Changed 5 years ago by zzz

Component: unspecifiedrouter/general

This could be a thing. Haven't tested it yet.

comment:4 Changed 5 years ago by str4d

Keywords: reliability proof-needed added
Milestone: 0.9.13

comment:5 Changed 4 years ago by str4d

Status: newopen

comment:6 Changed 18 months ago by Eche|on

Owner: set to zzz
Status: openassigned
Note: See TracTickets for help on using tickets.