Opened 5 years ago

Closed 3 years ago

#1250 closed defect (fixed)

I2Phex will not start properly

Reported by: hoarder Owned by:
Priority: minor Milestone: 0.9.27
Component: apps/plugins Version: 0.9.12
Keywords: I2Phex Cc:
Parent Tickets: Sensitive: no

Description

When attempting to launch I2Phex, the splash screen is visible for a brief moment before disappearing. Attempting to start the application again only results in a repeat of this process.


140413 ,0686(106.0) Error/phex.Main:: java.lang.NoClassDefFoundError?: net/i2p/I2PException - Exception: java.lang.NoClassDefFoundError?: net/i2p/I2PException

at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:190)
at phex.net.repres.PresentationManager?.createInstance(PresentationManager?.java:66)
at phex.net.repres.PresentationManager?.getInstance(PresentationManager?.java:55)
at phex.host.CaughtHostsContainer?.parseCaughtHostFromLine(CaughtHostsContainer?.java:660)
at phex.host.CaughtHostsContainer?.loadHostsFromFile(CaughtHostsContainer?.java:530)
at phex.host.CaughtHostsContainer?.initializeCaughtHostsContainer(CaughtHostsContainer?.java:146)
at phex.host.CaughtHostsContainer?.<init>(CaughtHostsContainer?.java:125)
at phex.host.HostManager?.<init>(HostManager?.java:56)
at phex.servent.Servent.<init>(Servent.java:177)
at phex.servent.Servent.<clinit>(Servent.java:62)
at phex.Main.main(Main.java:159)

Caused by: java.lang.ClassNotFoundException?: net.i2p.I2PException

at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
at java.security.AccessController?.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
at java.lang.ClassLoader?.loadClass(ClassLoader?.java:425)
at sun.misc.Launcher$AppClassLoader?.loadClass(Launcher.java:308)
at java.lang.ClassLoader?.loadClass(ClassLoader?.java:358)
… 12 more


I2P version: 0.9.12-0
Java version: Oracle Corporation 1.7.0_51 (OpenJDK Runtime Environment 1.7.0_51-b31)
Wrapper version: 3.5.22
Server version: 8.1.14.v20131031
Servlet version: Jasper JSP 2.1 Engine
Platform: Linux amd64 3.10.36-1-MANJARO
Processor: Core 2 (Conroe) (core2)
Jbigi: Locally optimized native BigInteger? library loaded from file
Encoding: UTF-8
Charset: UTF-8

Subtickets

Change History (6)

comment:1 Changed 5 years ago by viha12

I2Phex is unmaintained since 2011… Perhaps have a look to that tutorial: http://ugha.i2p/I2Phex

comment:2 Changed 5 years ago by str4d

Milestone: 0.9.13

comment:3 in reply to:  1 Changed 5 years ago by viha12

Replying to viha12:

I2Phex is unmaintained since 2011… Perhaps have a look to that tutorial: http://ugha.i2p/I2Phex

Pasted from http://ugha.i2p/I2Phex :
On Linux, I2Phex v3.2.6.106.0 plugin: when attempting to launch I2Phex, the splash screen is visible for a brief moment before disappearing. Attempting to start the application again only results in a repeat of this process.
This is a known issue (link to this page), "if the I2P user is not the user running X, it won't work" (ref: http://zzz.i2p/topics/576-new-i2phex-plugin ).

comment:4 Changed 3 years ago by hummingbird

Resolution: not a bug
Status: newclosed

comment:5 Changed 3 years ago by zzz

Milestone: 0.9.27
Resolution: not a bug
Status: closedreopened

comment:6 Changed 3 years ago by zzz

Resolution: fixed
Status: reopenedclosed

I don't recall ever seeing this ticket, and only after testing new plugin 3.2.8.0.0-b1 did it appear for me.

The class not found issue is not related to not running X. It was an error in the clients.config file.

See #1820 for details. Fixed in plugin 3.2.8.0.1-b1

Note: See TracTickets for help on using tickets.