Opened 5 years ago

Closed 15 months ago

#1256 closed defect (worksforme)

t.i2p.router.web.PluginStarter: Error starting up the client class net.i2p.jircii.GuiTest

Reported by: Eche|on Owned by:
Priority: minor Milestone:
Component: apps/console Version: 0.9.12
Keywords: proof-needed Cc:
Parent Tickets: Sensitive: no

Description (last modified by Eche|on)

Reported on IRC:
After upgrade from 0.9.12-8 to 0.9.12-10, the console router does not load into the web browser. Eepsites work.

<Kuri> SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder?".
<Kuri> SLF4J: Defaulting to no-operation (NOP) logger implementation
<Kuri> SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
<Kuri> SLF4J: Failed to load class "org.slf4j.impl.StaticMDCBinder".
<Kuri> SLF4J: Defaulting to no-operation MDCAdapter implementation.
<Kuri> SLF4J: See http://www.slf4j.org/codes.html#no_static_mdc_binder for further details.
<Kuri> 24/04/14 10:33:02 CRIT [iTest client] t.i2p.router.web.PluginStarter?: Error starting up the client class net.i2p.jircii.GuiTest?
<Kuri> java.lang.reflect.InvocationTargetException?
<Kuri> at sun.reflect.NativeMethodAccessorImpl?.invoke0(Native Method)
<Kuri> at sun.reflect.NativeMethodAccessorImpl?.invoke(Unknown Source)
<Kuri> at sun.reflect.DelegatingMethodAccessorImpl?.invoke(Unknown Source)
<Kuri> at java.lang.reflect.Method.invoke(Unknown Source)
<Kuri> at net.i2p.router.startup.LoadClientAppsJob?$RunApp?.run(LoadClientAppsJob?.java:282)
<Kuri> at java.lang.Thread.run(Unknown Source)
<Kuri> at net.i2p.util.I2PThread.run(I2PThread.java:84)
<Kuri> Caused by: java.lang.RuntimeException?: Cannot run the graphical application. I2P must be running on a graphical display, and it must be running as the logged-in user and not as a daemon.
<Kuri> at net.i2p.jircii.GuiTest?.main(GuiTest?.java:32)
<Kuri> … 7 more

Kuri> Java™ SE Runtime Environment (build 1.7.0_55-b14)

Subtickets

Change History (9)

comment:1 Changed 5 years ago by Eche|on

Description: modified (diff)

comment:2 Changed 5 years ago by Eche|on

Description: modified (diff)

comment:3 Changed 5 years ago by killyourtv

Status: newinfoneeded_new

That log doesn't show the problem with the router console loading. Are there any logs that show that?

comment:4 Changed 5 years ago by Eche|on

Status: infoneeded_newnew

Hi

Got only these logs, but AFAIK there were no more problems for router console.

comment:5 Changed 5 years ago by killyourtv

Status: newinfoneeded_new

We still need more info then because there is not a problem in these logs.

<Kuri> SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
<Kuri> SLF4J: Defaulting to no-operation (NOP) logger implementation
<Kuri> SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
<Kuri> SLF4J: Failed to load class "org.slf4j.impl.StaticMDCBinder".
<Kuri> SLF4J: Defaulting to no-operation MDCAdapter implementation.
<Kuri> SLF4J: See http://www.slf4j.org/codes.html#no_static_mdc_binder for further details.

This is from Bote. It always logs _if_ I2P-Bote is installed and running.

<Kuri> 24/04/14 10:33:02 CRIT  [iTest client] t.i2p.router.web.PluginStarter: Error starting up the client class net.i2p.jircii.GuiTest
<Kuri> java.lang.reflect.InvocationTargetException
<Kuri>  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
<Kuri>  at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
<Kuri>  at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
<Kuri>  at java.lang.reflect.Method.invoke(Unknown Source)
<Kuri>  at net.i2p.router.startup.LoadClientAppsJob$RunApp.run(LoadClientAppsJob.java:282)
<Kuri>  at java.lang.Thread.run(Unknown Source)
<Kuri>  at net.i2p.util.I2PThread.run(I2PThread.java:84)
<Kuri> Caused by: java.lang.RuntimeException: Cannot run the graphical application. I2P must be running on a graphical display, and it must be running as the logged-in user and not as a daemon.
<Kuri>  at net.i2p.jircii.GuiTest.main(GuiTest.java:32)
<Kuri>  ... 7 more

This is from the jIRCii plugin. Here we see that I2P is running as a daemon and the jIRCii plugin doesn't work in this configuration (as mentioned on http://stats.i2p/i2p/plugins/ and http://plugins.i2p/plugins/jircii/)

If there's a problem with loading the router console, as the user said, we need more info. Setting back to infoneeded because there's no evidence of a problem in these logs.

Last edited 5 years ago by killyourtv (previous) (diff)

comment:6 Changed 5 years ago by str4d

Component: otherapps/console
Keywords: proof-needed added
Milestone: 0.9.13

If I were to hazard a guess, it would be that the error in PluginStarter wasn't being caught properly by the routerconsole, causing it to crash. It isn't clear if the logs are from the router or wrapper (which would tell us if the routerconsole caught the error or not).

If there isn't a problem with the code, then it could be argued that there is a usability problem with plugins that can't be run by the I2P daemon. Perhaps we need a plugin option that specifies if it can be run headless or not.

Next step: someone could try and recreate the bug.

comment:7 Changed 5 years ago by user

Status: infoneeded_newnew

didnt echelon say the router consoole problem did not appear any more?
In the past there was a bug that sometimes prevented routerconsole from loading while eepsite still worked - just as described in OP - and that bug was fixed. Guess the jircii is unrelated to that bug. and plugin gui does not work if router is run as a service, as kytv already pointed out. So i think this bug can ble closed.

comment:8 Changed 4 years ago by str4d

Status: newopen

comment:9 Changed 15 months ago by zzz

Resolution: worksforme
Status: openclosed
Note: See TracTickets for help on using tickets.