Opened 5 years ago

Closed 5 years ago

#1262 closed defect (fixed)

bad integration of new routers before 0.9.12-14

Reported by: rfree Owned by:
Priority: major Milestone: 0.9.13
Component: router/general Version: 0.9.12
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

Hello, I observed on many computers (0.9.12-0) that i2p was drastically worse in performance: irc, sindie connection, even default i2p sites stoped worked for us on several computers; The main change was that they become firewalled, afair that is when problems started.

In summary: firewalled routers of 0.9.12-0 perform very poorly to the point of being almost not usable.

* 0.9.12-14 solves all the issues :) *
Solution: release this ASAP?
Please, we should release that version otherwise many new users will get impression that i2p does not work correctly.

We are talking about installed from scratch nodes (both versions), on all default settings, not using any bad idea like hidden mode, just normally running (on linux debian, java 7) - no user error.

Btw of this testing a not-yet-reported bug was observed: #1261
http://trac.i2p2.i2p/ticket/1261#ticket

Subtickets

Change History (4)

comment:1 Changed 5 years ago by rfree

Related discussion: http://zzz.i2p/topics/1605

comment:2 Changed 5 years ago by rfree

Detailed protocol of this experiment:

—-
test1: 0.9.12-14 (FROM MTN) from scratch, all defaults, FIREWALLED
at uptime 10 minutes: IRC works; most i2p work
Peers Active: 14 / 107 Fast: 18 High capacity: 32 Integrated: 139 Known: 201
Bandwidth in/out 5 min: 1.87 / 2.30 KBps
Tunnels Exploratory: 5 Client: 9 Participating: 0 Share ratio: 0.00
Congestion Job lag: 0 Message delay: 599 ms Backlog: 0
at uptime 30 minutes: torrents were added. Torrents work well, irc works, sites work.

restarted at 1 hour, in few minutes all started to work well. Btw: torrents did not auto-start.
15 minutes after restart:
Peers Active: 20 / 234 Fast: 24 High capacity: 97 Integrated: 209 Known: 308
Bandwidth in/out 5 min: 38.94 / 19.95 KBps
Tunnels Exploratory: 6 Client: 21 Participating: 0 Share ratio: 0.00
Congestion Job lag: 0 Message delay: 347 ms Backlog: 0

—-
test2: 0.9.12-0 from scratch, all defaults, FIREWALLED
at uptime 30 minutes: IRC works weakly, took 30 min to connect, pages work weak (50%)
Peers Active: 10 / 180 Fast: 18 High capacity: 28 Integrated: 207 Known: 289
Bandwidth in/out 5 min: 0.55 / 0.97 KBps
Tunnels Exploratory: 5 Client: 7 Participating: 0 Share ratio: 0.00
Congestion Job lag: 0 Message delay: 544 ms Backlog: 0
sites do not work like this: Warning: Eepsite Unreachable Could not find the following destination: http://zzz.i2p/
after few retried you can reach them though;
Opened test pages (sites were opened in tripples eg 1,2,3 then wait, then tested next 3 etc)

http://anoncoin.i2p/ ok

! http://git.repo.i2p/w - Could not find the following destination:

http://trac.i2p2.i2p/report/1 ok

! http://zzz.i2p/ - Could not find the following destination:
! http://diftracker.i2p/ - Could not find the following destination:

http://echelon.i2p/ ok

! http://i2p-projekt.i2p/en/faq - Could not find the following destination:
! http://forum.i2p/ - Could not find the following destination:

http://open4you.i2p/ ok

! http://id3nt.i2p/ - Could not find the following destination:
! http://i2p-javadocs.i2p/ - Could not find the following destination:

http://tracker2.postman.i2p/ ok

at uptime 45 minutes - still pages do not open ( http://zzz.i2p tested 2 more times, same error)
Peers Active: 10 / 187 Fast: 18 High capacity: 135 Integrated: 207 Known: 299
Bandwidth in/out 5 min: 0.89 / 1.58 KBps
Tunnels Exploratory: 4 Client: 8 Participating: 0 Share ratio: 0.00
Congestion Job lag: 0 Message delay: 570 ms Backlog: 0

—-
test2-part2:will add torrents now (at uptime 50 minutes)

  • magnet:?xt=urn:btih:c7fc714f75624601979f54bca0ed05d92feda3e4&dn=I2P+Propaganda&tr=http://tracker2.postman.i2p/announce.php
  • magnet:?xt=urn:btih:ebd3c395386d6b2e8d43ecec598efac85b184bbe&dn=TED+Richard+Ledgett%3A+The+NSA+responds+to+Edward+Snowden%E2%80%99s+TED+Talk&tr=http://tracker2.postman.i2p/announce.php
  • magnet:?xt=urn:btih:0a8260a485857b73a57e05579b2fe6960c7f9226&dn=Schneier+and+Applebaum+at+COPS+%28EPFL%29&tr=http://tracker2.postman.i2p/announce.php

~15 minutes after adding 1st torrent, IRC stopped working. Situation is now (after adding 2 more torrents):
Peers Active: 13 / 68 Fast: 24 High capacity: 43 Integrated: 216 Known: 300
Bandwidth in/out 5 min: 54.72 / 13.71 KBps
Tunnels Exploratory: 6 Client: 19 Participating: 0 Share ratio: 0.00
Congestion Job lag: 0 Message delay: 368 ms Backlog: 0

Torrents works fine: OK: 4 / 6 peers , Seeding: 0 / 19 peers , OK: 6 / 7 peers
later the seeding torrent fails as "Tracker Error: 0 / 19 peers".
IRC starts working again.
Still half of i2p pages does not work.

—-
test3: 0.9.12-14 (FROM MTN) from scratch, all defaults, FIREWALLED

After uptime 12 minutes all works very well (IRC and sites).
Condition is:

Peers Active: 13 / 119 Fast: 18 High capacity: 19 Integrated: 142 Known: 233
Bandwidth in/out 5 min: 7.22 / 3.59 KBps
Tunnels Exploratory: 4 Client: 8 Participating: 0 Share ratio: 0.00
Congestion Job lag: 0 Message delay: 486 ms Backlog: 0

At uptime 25 minutes, for 5 minutes things started to work worse, could not connect to most eepsites,
perhaps this was caused by torrents spiking to ~75 KB/s download.
At this time (after the spike has gone down on it's own) istuation is (look at detailed bw stats)
Peers Active: 20 / 142 Fast: 24 High capacity: 22 Integrated: 143 Known: 240
Bandwidth in/out 3 sec: 54.09 / 11.16 KBps 5 min: 50.72 / 15.88 KBps Total: 16.62 / 6.66 KBps
Tunnels Exploratory: 5 Client: 26 Participating: 0 Share ratio: 0.00
Congestion Job lag: 0 Message delay: 679 ms Backlog: 0

after pausing 2 torrents and letting 1 run, all things were working perfectly again;
Stats then:
Peers Active: 15 / 155 Fast: 24 High capacity: 27 Integrated: 143 Known: 243
Bandwidth in/out 3 sec: 66.59 / 14.49 KBps 5 min: 52.93 / 16.68 KBps Total: 25.93 / 8.92 KBps
Tunnels Exploratory: 6 Client: 15 Participating: 0 Share ratio: 0.00
Congestion Job lag: 0 Message delay: 296 ms Backlog: 0

comment:3 Changed 5 years ago by zzz

thanks for testing

comment:4 Changed 5 years ago by zzz

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.