Opened 6 years ago

Closed 5 years ago

#1269 closed defect (fixed)

ava.lang.ArrayIndexOutOfBoundsException: 7274

Reported by: Eche|on Owned by: zzz
Priority: major Milestone: 0.9.13
Component: apps/susimail Version: 0.9.12
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

HTTP ERROR 500

Problem accessing /susimail/susimail. Reason:

Server Error

Caused by:

java.lang.ArrayIndexOutOfBoundsException?: 7274

at i2p.susi.webmail.MailPart?.<init>(MailPart?.java:152)
at i2p.susi.webmail.MailPart?.<init>(MailPart?.java:189)
at i2p.susi.webmail.MailPart?.<init>(MailPart?.java:178)
at i2p.susi.webmail.MailPart?.<init>(MailPart?.java:178)
at i2p.susi.webmail.MailPart?.<init>(MailPart?.java:178)
at i2p.susi.webmail.MailPart?.<init>(MailPart?.java:55)
at i2p.susi.webmail.Mail.setBody(Mail.java:118)
at i2p.susi.webmail.MailCache?.getMail(MailCache?.java:257)
at i2p.susi.webmail.WebMail?.processLogin(WebMail?.java:778)
at i2p.susi.webmail.WebMail?.processStateChangeButtons(WebMail?.java:855)
at i2p.susi.webmail.WebMail?.processRequest(WebMail?.java:1586)
at i2p.susi.webmail.WebMail?.doPost(WebMail?.java:1959)
at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:755)
at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:848)
at org.eclipse.jetty.servlet.ServletHolder?.handle(ServletHolder?.java:684)
at org.eclipse.jetty.servlet.ServletHandler?.doHandle(ServletHandler?.java:501)
at org.eclipse.jetty.server.handler.ScopedHandler?.handle(ScopedHandler?.java:137)
at org.eclipse.jetty.security.SecurityHandler?.handle(SecurityHandler?.java:557)
at org.eclipse.jetty.server.session.SessionHandler?.doHandle(SessionHandler?.java:231)
at org.eclipse.jetty.server.handler.ContextHandler?.doHandle(ContextHandler?.java:1086)
at org.eclipse.jetty.servlet.ServletHandler?.doScope(ServletHandler?.java:428)
at org.eclipse.jetty.server.session.SessionHandler?.doScope(SessionHandler?.java:193)
at org.eclipse.jetty.server.handler.ContextHandler?.doScope(ContextHandler?.java:1020)
at org.eclipse.jetty.server.handler.ScopedHandler?.handle(ScopedHandler?.java:135)
at org.eclipse.jetty.server.handler.ContextHandlerCollection?.handle(ContextHandlerCollection?.java:255)
at org.eclipse.jetty.server.handler.HandlerCollection?.handle(HandlerCollection?.java:154)
at org.eclipse.jetty.server.handler.HandlerWrapper?.handle(HandlerWrapper?.java:116)
at org.eclipse.jetty.server.Server.handle(Server.java:370)
at org.eclipse.jetty.server.AbstractHttpConnection?.handleRequest(AbstractHttpConnection?.java:494)
at org.eclipse.jetty.server.AbstractHttpConnection?.content(AbstractHttpConnection?.java:982)
at org.eclipse.jetty.server.AbstractHttpConnection?$RequestHandler?.content(AbstractHttpConnection?.java:1043)
at org.eclipse.jetty.http.HttpParser?.parseNext(HttpParser?.java:865)
at org.eclipse.jetty.http.HttpParser?.parseAvailable(HttpParser?.java:240)
at org.eclipse.jetty.server.AsyncHttpConnection?.handle(AsyncHttpConnection?.java:82)
at org.eclipse.jetty.io.nio.SelectChannelEndPoint?.handle(SelectChannelEndPoint?.java:667)
at org.eclipse.jetty.io.nio.SelectChannelEndPoint?$1.run(SelectChannelEndPoint?.java:52)
at java.util.concurrent.ThreadPoolExecutor?.runWorker(ThreadPoolExecutor?.java:1145)
at java.util.concurrent.ThreadPoolExecutor?$Worker.run(ThreadPoolExecutor?.java:615)
at java.lang.Thread.run(Thread.java:744)

Log section:
I2P version: 0.9.12-14
Java version: Oracle Corporation 1.7.0_45 (Java™ SE Runtime Environment 1.7.0_45-b18)
Wrapper version: 3.5.13
Server version: 8.1.14.v20131031
Servlet version: Jasper JSP 2.1 Engine
Platform: Linux amd64 3.13-1-amd64

Subtickets

Change History (7)

comment:1 Changed 6 years ago by zzz

Owner: set to zzz
Status: newaccepted

Don't see exactly how this happened but I'll throw in some synchronization.

comment:2 Changed 6 years ago by zzz

Status: acceptedtesting

Locking added in 8e16cb3155aa5ffa3a1bdab33a6e2d1a7e92a997 to be 0.9.12-16, might help, might not.

comment:3 Changed 6 years ago by zzz

Status: testingneeds_work

OP reports same error on -16

comment:4 Changed 6 years ago by zzz

Status: needs_worktesting

comment:5 Changed 6 years ago by zzz

Status: testingneeds_work

still not fixed

comment:6 Changed 6 years ago by zzz

Status: needs_worktesting

fixed in 85f48974b29c00cd160abb679d657241d63fa731 0.9.12-18-rc
The problem was with Content-type: message/foo attachments. Bug present since first checkin 2005-02-17.

Last edited 6 years ago by zzz (previous) (diff)

comment:7 Changed 5 years ago by zzz

Resolution: fixed
Status: testingclosed
Note: See TracTickets for help on using tickets.