Opened 5 years ago

Closed 3 years ago

Last modified 3 years ago

#1297 closed defect (fixed)

syndie: crash when configuring archive (with workaround)

Reported by: killyourtv Owned by:
Priority: minor Milestone:
Component: apps/syndie Version:
Keywords: crash, glib, gobject Cc:
Parent Tickets:

Description (last modified by killyourtv)

I'm not sure that there's anything for 'us' to fix, but I wanted to document the problem and a workaround that I've found. The bug may actually be in Debian unstable & Ubuntu Trusty (another user reported this in #syndie about a month ago).

Steps to reproduce:
1) Go to the Syndicate tab
2) Right click an archive
3) Click Cancel or OK. It doesn't matter

Result: Crash

This was shown in the console after starting Syndie (70 times, snipped for brevity)

(Syndie:12249): GLib-GObject-CRITICAL **: g_closure_add_invalidate_notifier: assertion 'closure->n_inotifiers < CLOSURE_MAX_N_INOTIFIERS' failed

At this point I right-clicked an archive and picked Settings:

(Syndie:12249): GLib-GObject-WARNING **: /tmp/buildd/glib2.0-2.40.0/./gobject/gclosure.c:688: unable to remove uninstalled invalidation notifier: 0x7f10c0e87e00 (0x7f10ececea10)

(Syndie:12249): GLib-GObject-WARNING **: /tmp/buildd/glib2.0-2.40.0/./gobject/gclosure.c:688: unable to remove uninstalled invalidation notifier: 0x7f10c0e87e00 (0x7f10ecc39ad0)

(Syndie:12249): GLib-GObject-WARNING **: /tmp/buildd/glib2.0-2.40.0/./gobject/gclosure.c:688: unable to remove uninstalled invalidation notifier: 0x7f10c0e87e00 (0x7f10ecc39e10)

(Syndie:12249): GLib-GObject-WARNING **: /tmp/buildd/glib2.0-2.40.0/./gobject/gclosure.c:688: unable to remove uninstalled invalidation notifier: 0x7f10c0e87e00 (0x7f10ecec10a0)

(Syndie:12249): GLib-GObject-WARNING **: /tmp/buildd/glib2.0-2.40.0/./gobject/gclosure.c:688: unable to remove uninstalled invalidation notifier: 0x7f10c0e87e00 (0x7f10ecec1240)

(Syndie:12249): GLib-GObject-WARNING **: /tmp/buildd/glib2.0-2.40.0/./gobject/gclosure.c:688: unable to remove uninstalled invalidation notifier: 0x7f10c0e87e00 (0x7f10ecec13e0)

(Syndie:12249): GLib-GObject-WARNING **: /tmp/buildd/glib2.0-2.40.0/./gobject/gclosure.c:688: unable to remove uninstalled invalidation notifier: 0x7f10c0e87e00 (0x7f10ecec1580)

(Syndie:12249): GLib-GObject-WARNING **: /tmp/buildd/glib2.0-2.40.0/./gobject/gclosure.c:688: unable to remove uninstalled invalidation notifier: 0x7f10c0e87e00 (0x7f10ecec1720)

(Syndie:12249): GLib-GObject-WARNING **: /tmp/buildd/glib2.0-2.40.0/./gobject/gclosure.c:688: unable to remove uninstalled invalidation notifier: 0x7f10c0e87e00 (0x7f10ecd08930)

(Syndie:12249): GLib-GObject-WARNING **: /tmp/buildd/glib2.0-2.40.0/./gobject/gclosure.c:688: unable to remove uninstalled invalidation notifier: 0x7f10c0e87e00 (0x7f10ecd08a00)

(Syndie:12249): GLib-GObject-WARNING **: /tmp/buildd/glib2.0-2.40.0/./gobject/gclosure.c:688: unable to remove uninstalled invalidation notifier: 0x7f10c0e87e00 (0x7f10ecd08ad0)

(Syndie:12249): GLib-GObject-WARNING **: /tmp/buildd/glib2.0-2.40.0/./gobject/gclosure.c:688: unable to remove uninstalled invalidation notifier: 0x7f10c0e87e00 (0x7f10ecc9e7e0)

(Syndie:12249): GLib-GObject-CRITICAL **: g_object_get_qdata: assertion 'G_IS_OBJECT (object)' failed
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007f10c0e81718, pid=12249, tid=139710764336896
#
# JRE version: OpenJDK Runtime Environment (7.0_55-b14) (build 1.7.0_55-b14)
# Java VM: OpenJDK 64-Bit Server VM (24.51-b03 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libgobject-2.0.so.0+0x19718]  g_object_get_qdata+0x18
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /home/USER/hs_err_pid12249.log
#
# If you would like to submit a bug report, please include
# instructions on how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Aborted

Now the workaround:

sudo -u your_user_account $COMMAND_TO_START_SYNDIE

I don't yet know why this works, I only know that it does. I found this because I tried running Syndie as my anonymous system account and that worked:

xauth extract - :0 |sudo -u kytv xauth merge -
sudo -u kytv -H syndie

That led me to believe that the problem was with my non-anon system profile, but logging in directly with that anonymous account failed.

Perhaps it's something that "we" can do differently to avoid this, but I think it's a problem that needs to be fixed upstream.

Subtickets

Attachments (1)

sanitized.hs_err_pid12249.log (97.7 KB) - added by killyourtv 5 years ago.
The referenced hs_err_pid12249.log with sanitation

Download all attachments as: .zip

Change History (9)

Changed 5 years ago by killyourtv

The referenced hs_err_pid12249.log with sanitation

comment:1 Changed 5 years ago by killyourtv

  • Description modified (diff)

comment:2 Changed 5 years ago by killyourtv

Updating swt fixes it too. Both the SWT we bundle in Syndie and the SWT in Debian cause the crash. Updating to the SWT at http://www.eclipse.org/downloads/download.php?file=/eclipse/downloads/drops4/R-4.3-201306052000/swt-4.3-gtk-linux-x86_64.zip fixed it for me.

I'd like to do a new Syndie release with updated SWT, the fix for ticket #1282, and hummingbird's updated icons.

comment:3 Changed 4 years ago by killyourtv

Fix committed in 5f36444987bb6934b75b9d0866ea9860eaf046a5

comment:4 Changed 3 years ago by str4d

  • Status changed from new to open

comment:5 Changed 3 years ago by zzz

  • Resolution set to worksforme
  • Status changed from open to closed

comment:6 Changed 3 years ago by zzz

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:7 Changed 3 years ago by zzz

  • Resolution set to fixed
  • Status changed from reopened to closed

Correction, kytv fixed it with SWT 4.3. This will be released in 1.106/107, although I'll probably update it again to SWT 4.5 before the release.

comment:8 Changed 3 years ago by zzz

I can't reproduce this with 3.8.2, and there's other problems with the 4.x series (see e.g. #1828).

Reverted to 3.8.2. in dev build 1.106b-4

Note: See TracTickets for help on using tickets.