Opened 5 years ago

Closed 5 years ago

#1313 closed defect (fixed)

torrents added via magnets lack announce and announce-list (but only before restart?)

Reported by: killyourtv Owned by: zzz
Priority: minor Milestone: 0.9.14
Component: apps/i2psnark Version: 0.9.13
Keywords: Cc:
Parent Tickets:

Description (last modified by killyourtv)

When a torrent is fetched in I2PSnark using a magnet, according to the snark UI, the tracker(s) is/are not retained.

This is easily reproduced:

  1. Add a torrent using its magnet address, such as magnet:?xt=urn:btih:3c66dea129ea3a900faf96472e585513452c868c&dn=i2pupdate-0.9.13.su3&tr=http://tracker2.postman.i2p/announce.php

The torrent file will be fetched, but the Details at Postman tracker icon will not be displayed. The torrent information page will not show the tracker either, even though the tracker was in the magnet link and is in the retrieved torrent file.

$ btshowmetainfo i2pupdate-0.9.13.su3.torrent 
btshowmetainfo 20030621 - decode BitTorrent metainfo files

metainfo file.: i2pupdate-0.9.13.su3.torrent
info hash.....: 3c66dea129ea3a900faf96472e585513452c868c
file name.....: i2pupdate-0.9.13.su3
file size.....: 3859346 (58 * 65536 + 58258)
announce url..: http://tracker2.postman.i2p/announce.php

Download finished: i2pupdate-0.9.13.su3
Starting up torrent i2pupdate-0.9.13.su3
Metainfo received for Magnet 3c66dea129ea3a900faf96472e585513452c868c (i2pupdate-0.9.13.su3)
Fetching Magnet 3c66dea129ea3a900faf96472e585513452c868c (i2pupdate-0.9.13.su3)
Starting up torrent Magnet 3c66dea129ea3a900faf96472e585513452c868c (i2pupdate-0.9.13.su3)

It seems to me that the tracker would be recognized when Snark starts again and reads the *.torrent files, but I have not restarted since noticing this bug.

Subtickets

Change History (5)

comment:1 Changed 5 years ago by killyourtv

  • Description modified (diff)
  • Summary changed from torrents added via magnets lack announce or announce-list (only before restart?) to torrents added via magnets lack announce and announce-list (but only before restart?)

comment:2 Changed 5 years ago by killyourtv

Yes, the tracker information will be seen after I2P is restarted.

comment:3 Changed 5 years ago by zzz

yes. unimplemented.

Related / dup: #964

comment:4 Changed 5 years ago by killyourtv

This has some relation to #964 but it's not a duplicate; this ticket is for the case of there being no trackers for the torrent (until restart) if the download is fetched via magnet.

I wasn't sure whether Snark would still talk to the tracker to report the torrent's progress or if it'd just communicate via the DHT/OpenTrackers, but I suppose it could be more of a cosmetic problem than a functionality problem.

comment:5 Changed 5 years ago by zzz

  • Resolution set to fixed
  • Status changed from new to closed

In 1f9b91f318a0f2369243844a3cf7f485528492d7 0.9.13-8

Note: See TracTickets for help on using tickets.