Opened 5 years ago

Closed 3 years ago

#1330 closed defect (fixed)

android: implement ability to edit i2ptunnel config

Reported by: killyourtv Owned by: str4d
Priority: minor Milestone: 0.9.20
Component: apps/android Version: 0.9.13
Keywords: Cc:
Parent Tickets:

Description

We can create new tunnels and we can delete tunnels, but there isn't currently a way to edit existing tunnels. At the moment it seems there are two options: delete and recreate or edit the config files manually, assuming your device is rooted.

(I'm just putting this here to track its progress; this "shortcoming" is almost certainly known by all.)

Subtickets

Change History (6)

comment:1 Changed 4 years ago by str4d

  • Milestone set to 0.9.19
  • Owner changed from zzz to str4d
  • Status changed from new to accepted

Planning this for the next release. I was struggling to find a good design, but I have settled on using a PreferenceFragment to take care of it (rather than designing something like a Contacts edit page). This is possible thanks to a relatively new library that provides a support version of PreferenceFragment (which the Android Support Library has not implemented).

comment:2 Changed 4 years ago by str4d

  • Status changed from accepted to testing

Pushed in 471a65def1b45d4509079d40c2fad945c6876e94 (and prior commits). Untested, probably buggy.

comment:3 Changed 4 years ago by str4d

  • Status changed from testing to needs_work

Make that definitely buggy. Have fixed some bugs, but there is more to do. See #815 for related discussion.

comment:4 Changed 4 years ago by str4d

  • Milestone changed from 0.9.19 to 0.9.20
  • Status changed from needs_work to accepted

The edit tunnel page bugs are now fixed and it seems to be working fine, but saving the config blocks while client tunnels are starting, which locks up the UI and causes the app to throw an "Application Not Responding". The block is caused by the saveConfig() call waiting for a lock. See the discussion in #815.

I will disable the edit feature for the 0.9.19 release, because the required fix for #815 is targeted for 0.9.20.

comment:5 Changed 4 years ago by str4d

  • Status changed from accepted to testing

The required fix in #815 has landed, and tunnels can now be configured in the latest builds. Testing required.

comment:6 Changed 3 years ago by str4d

  • Resolution set to fixed
  • Status changed from testing to closed

Presumed working!

Note: See TracTickets for help on using tickets.