Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1342 closed defect (fixed)

i2psnark: ':' in file name

Reported by: zzz Owned by: zzz
Priority: minor Milestone: 0.9.15
Component: apps/i2psnark Version: 0.9.14
Keywords: Cc:
Parent Tickets:

Subtickets

Change History (5)

comment:1 Changed 4 years ago by zzz

  • Status changed from new to accepted

Also bottom of http://forum.i2p/viewtopic.php?t=11490

Need to bypass filter

comment:2 Changed 4 years ago by zzz

The ':' has to be in a file name (not top=level directory name) to fail. Curses to URI which is looking for a scheme in a path, and not escaping it. Seems like a URI bug but no use complaining, gotta fix it in our code.

comment:3 Changed 4 years ago by zzz

  • Resolution set to fixed
  • Status changed from accepted to closed

Both ':' and filter issues fixed in e8883e85a7761bbda9df59b3f6b57601cc01bb5a 0.9.1.14-7

comment:4 Changed 4 years ago by zzz

Was having trouble consistently reproducing some of these issues. Turns out that some browsers behave differently in what they send. Firefox does some escaping for you that Chrome does not. More fixes checked in and more coming before 0.9.15.

comment:5 Changed 4 years ago by zzz

':' fix in 0.9.14.1-16-rc
'[]' fix in 0.9.14.1-17-rc

Note: See TracTickets for help on using tickets.