Opened 5 years ago

Closed 2 years ago

#1364 closed defect (fixed)

HTTPS to outproxy broken

Reported by: zzz Owned by:
Priority: minor Milestone: 0.9.29
Component: apps/i2ptunnel Version: 0.9.14.1
Keywords: Cc:
Parent Tickets:

Subtickets

Change History (4)

comment:1 Changed 5 years ago by zzz

I glanced at the code and I don't see the problem. For further research.

comment:2 Changed 5 years ago by zzz

  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce this. I suspect that Orchid crashed or stopped working (see #1207 #1213 #1220) and then an SSL outproxy wasn't configured in i2ptunnel. There is no SSL outproxy set by default. I'll add it for 0.9.15.

comment:3 Changed 2 years ago by zzz

  • Milestone changed from 0.9.15 to 0.9.29
  • Resolution worksforme deleted
  • Status changed from closed to reopened

Confirmed bug in CONNECT (4445) proxy only. See #1895. Workaround is to use 4444 proxy.

comment:4 Changed 2 years ago by zzz

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in 36e82a882c02917f7f60e5203d53201b4fccdd55 to be 0.9.28-5

Note: See TracTickets for help on using tickets.