Opened 5 years ago

Closed 5 years ago

#1370 closed defect (fixed)

ArrayIndexOutOfBoundsException

Reported by: Eche|on Owned by:
Priority: minor Milestone: 0.9.15
Component: streaming Version: 0.9.14.1
Keywords: Cc:
Parent Tickets: Sensitive: no

Description (last modified by zzz)

8/29/14 5:46:15 PM ERROR [1.2.3.4:5678] .i2ptunnel.I2PTunnelHTTPServer: Error connecting to HTTP server /1.2.3.4:5678

java.net.ConnectException?: Connection refused
at java.net.PlainSocketImpl?.socketConnect(Native Method)
at java.net.AbstractPlainSocketImpl?.doConnect(AbstractPlainSocketImpl?.java:345)
at java.net.AbstractPlainSocketImpl?.connectToAddress(AbstractPlainSocketImpl?.java:206)
at java.net.AbstractPlainSocketImpl?.connect(AbstractPlainSocketImpl?.java:188)
at java.net.SocksSocketImpl?.connect(SocksSocketImpl?.java:392)
at java.net.Socket.connect(Socket.java:589)
at java.net.Socket.connect(Socket.java:538)
at java.net.Socket.<init>(Socket.java:434)
at java.net.Socket.<init>(Socket.java:244)
at net.i2p.i2ptunnel.I2PTunnelServer.getSocket(I2PTunnelServer.java:611)
at net.i2p.i2ptunnel.I2PTunnelServer.getSocket(I2PTunnelServer.java:566)
at net.i2p.i2ptunnel.I2PTunnelHTTPServer.blockingHandle(I2PTunnelHTTPServer.java:279)
at net.i2p.i2ptunnel.I2PTunnelServer$Handler.run(I2PTunnelServer.java:510)
at java.util.concurrent.ThreadPoolExecutor?.runWorker(ThreadPoolExecutor?.java:1142)
at java.util.concurrent.ThreadPoolExecutor?$Worker.run(ThreadPoolExecutor?.java:617)
at java.lang.Thread.run(Thread.java:745)

8/28/14 12:07:40 AM ERROR [xxx] .i2ptunnel.I2PTunnelHTTPServer: Uncaught exception accepting

java.lang.ArrayIndexOutOfBoundsException?
at net.i2p.client.streaming.impl.Packet.writePacket(Packet.java:484)
at net.i2p.client.streaming.impl.Packet.verifySignature(Packet.java:680)
at net.i2p.client.streaming.impl.ConnectionPacketHandler?.verifySignature(ConnectionPacketHandler?.java:557)
at net.i2p.client.streaming.impl.ConnectionPacketHandler?.verifyPacket(ConnectionPacketHandler?.java:483)
at net.i2p.client.streaming.impl.ConnectionPacketHandler?.receivePacket(ConnectionPacketHandler?.java:46)
at net.i2p.client.streaming.impl.ConnectionManager?.receiveConnection(ConnectionManager?.java:287)
at net.i2p.client.streaming.impl.ConnectionHandler?.accept(ConnectionHandler?.java:179)
at net.i2p.client.streaming.impl.I2PSocketManagerFull.receiveSocket(I2PSocketManagerFull.java:131)
at net.i2p.client.streaming.impl.I2PServerSocketFull.accept(I2PServerSocketFull.java:30)
at net.i2p.i2ptunnel.I2PTunnelServer.run(I2PTunnelServer.java:424)
at java.lang.Thread.run(Thread.java:745)
at net.i2p.util.I2PThread.run(I2PThread.java:84)

8/28/14 12:07:40 AM ERROR [xxx] p.client.streaming.impl.Packet: payload.length: 396 buffer.length: 1197 cur: 929

java.lang.ArrayIndexOutOfBoundsException?
at net.i2p.client.streaming.impl.Packet.writePacket(Packet.java:484)
at net.i2p.client.streaming.impl.Packet.verifySignature(Packet.java:680)
at net.i2p.client.streaming.impl.ConnectionPacketHandler?.verifySignature(ConnectionPacketHandler?.java:557)
at net.i2p.client.streaming.impl.ConnectionPacketHandler?.verifyPacket(ConnectionPacketHandler?.java:483)
at net.i2p.client.streaming.impl.ConnectionPacketHandler?.receivePacket(ConnectionPacketHandler?.java:46)
at net.i2p.client.streaming.impl.ConnectionManager?.receiveConnection(ConnectionManager?.java:287)
at net.i2p.client.streaming.impl.ConnectionHandler?.accept(ConnectionHandler?.java:179)
at net.i2p.client.streaming.impl.I2PSocketManagerFull.receiveSocket(I2PSocketManagerFull.java:131)
at net.i2p.client.streaming.impl.I2PServerSocketFull.accept(I2PServerSocketFull.java:30)
at net.i2p.i2ptunnel.I2PTunnelServer.run(I2PTunnelServer.java:424)
at java.lang.Thread.run(Thread.java:745)
at net.i2p.util.I2PThread.run(I2PThread.java:84)

8/28/14 12:07:22 AM ERROR [xxx] .i2ptunnel.I2PTunnelHTTPServer: Uncaught exception accepting

java.lang.ArrayIndexOutOfBoundsException?
at net.i2p.client.streaming.impl.Packet.writePacket(Packet.java:484)
at net.i2p.client.streaming.impl.Packet.verifySignature(Packet.java:680)
at net.i2p.client.streaming.impl.ConnectionPacketHandler?.verifySignature(ConnectionPacketHandler?.java:557)
at net.i2p.client.streaming.impl.ConnectionPacketHandler?.verifyPacket(ConnectionPacketHandler?.java:483)
at net.i2p.client.streaming.impl.ConnectionPacketHandler?.receivePacket(ConnectionPacketHandler?.java:46)
at net.i2p.client.streaming.impl.ConnectionManager?.receiveConnection(ConnectionManager?.java:287)
at net.i2p.client.streaming.impl.ConnectionHandler?.accept(ConnectionHandler?.java:179)
at net.i2p.client.streaming.impl.I2PSocketManagerFull.receiveSocket(I2PSocketManagerFull.java:131)
at net.i2p.client.streaming.impl.I2PServerSocketFull.accept(I2PServerSocketFull.java:30)
at net.i2p.i2ptunnel.I2PTunnelServer.run(I2PTunnelServer.java:424)
at java.lang.Thread.run(Thread.java:745)
at net.i2p.util.I2PThread.run(I2PThread.java:84)

8/28/14 12:07:22 AM ERROR [xxx] p.client.streaming.impl.Packet: payload.length: 396 buffer.length: 1197 cur: 929

java.lang.ArrayIndexOutOfBoundsException?
at net.i2p.client.streaming.impl.Packet.writePacket(Packet.java:484)
at net.i2p.client.streaming.impl.Packet.verifySignature(Packet.java:680)
at net.i2p.client.streaming.impl.ConnectionPacketHandler?.verifySignature(ConnectionPacketHandler?.java:557)
at net.i2p.client.streaming.impl.ConnectionPacketHandler?.verifyPacket(ConnectionPacketHandler?.java:483)
at net.i2p.client.streaming.impl.ConnectionPacketHandler?.receivePacket(ConnectionPacketHandler?.java:46)
at net.i2p.client.streaming.impl.ConnectionManager?.receiveConnection(ConnectionManager?.java:287)
at net.i2p.client.streaming.impl.ConnectionHandler?.accept(ConnectionHandler?.java:179)
at net.i2p.client.streaming.impl.I2PSocketManagerFull.receiveSocket(I2PSocketManagerFull.java:131)
at net.i2p.client.streaming.impl.I2PServerSocketFull.accept(I2PServerSocketFull.java:30)
at net.i2p.i2ptunnel.I2PTunnelServer.run(I2PTunnelServer.java:424)
at java.lang.Thread.run(Thread.java:745)
at net.i2p.util.I2PThread.run(I2PThread.java:84)

Subtickets

Change History (1)

comment:1 Changed 5 years ago by zzz

Component: apps/i2ptunnelstreaming
Description: modified (diff)
Resolution: fixed
Status: newclosed

This is a streaming bug with long signing key types (P521 and RSA). Your logs were caused by my testing. I wasn't explicitly testing with your server, but my router tried to fetch news.xml.

This was fixed in 0.9.14.1-11 49fc1472183daee34eb217b8db82bf80496926d4

Thanks for the report and sorry for my testing causing errors in your logs.

Note: See TracTickets for help on using tickets.