Opened 5 years ago

Closed 5 years ago

#1387 closed defect (no response)

i2psnark cannot seed outside of data dir

Reported by: ihave2p Owned by: zzz
Priority: major Milestone: 0.9.16
Component: apps/i2psnark Version: 0.9.15
Keywords: Cc:
Parent Tickets:

Description

Steps to reproduce:
$ sudo chown -R i2p:i2p /path/outside/i2psnark ; sudo -u i2p ln -s /path/outside/i2psnark/data.i.want.to.seed /path/to/i2psnark/
$ echo $?
0

i2psnark reports: "Cannot open ... (Permission denied)"

I cannot reproduce this (or the bugs listed below) on another machine with cloned software specs *but* the other machine is an i386 running Linux 3.14.19-1-lts.

Note: a growing trend of oddities may point to the possibility that i2p doesn't like an unidentifiable processor and may misbehave as a result. See also: http://trac.i2p2.i2p/ticket/1386 and http://trac.i2p2.i2p/ticket/1382

Subtickets

Attachments (2)

problematic.txt (374 bytes) - added by ihave2p 5 years ago.
non-problematic.txt (378 bytes) - added by ihave2p 5 years ago.

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by ihave2p

Changed 5 years ago by ihave2p

comment:1 Changed 5 years ago by zzz

  • Status changed from new to infoneeded_new

Works for me.

When did it report the permission error? When you attempted to create the torrent? Or? look in the router logs. If there's more information please report it. Is the problem reported for a directory or a file?

Your theory of an unidentified processor leading to this and other issues is highly unlikely to be correct. We use processor ID to optimize cryptographic operations, and that's it.

Note that symlinking from the i2psnark directory has always worked. This is not a 0.9.15 feature. What's new in 0.9.15 is you can enter /path/outside/i2psnark/data.i.want.to.seed into the torrent creation form, no symlink required.

I suggest you look harder for why there's a permissions problem.

comment:2 Changed 5 years ago by ihave2p

  • Resolution set to no response
  • Status changed from infoneeded_new to closed

My sincerest apologies, how embarrassing, it turned out to be a strange permission issue between the drives that I was working with, thus it worked on a different machine.

As for the CPU, I can't imagine how it would apply, but I was stabbing in the dark looking for parallels since the code looked fine.

JFTR: the torrent was created without error, nothing reported in logs - the problem was user error X-/

Closing ticket.

Note: See TracTickets for help on using tickets.