Opened 5 years ago

Closed 5 years ago

#1391 closed defect (fixed)

magnet with &dn=some%27text rejected by snark

Reported by: killyourtv Owned by: zzz
Priority: minor Milestone: 0.9.16
Component: apps/i2psnark Version: 0.9.15
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

A magnet with %27 in the dn= bit of a magnet URL could not be added to snark. Instead it was rejected with "Invalid URL". Removing %27 allowed the torrent to be added.

Subtickets

Change History (2)

comment:1 Changed 5 years ago by zzz

Status: newaccepted

Confirmed. I saw a complaint in IRC about % chars, just before the 0.9.15 release, and I did a quick test, and it worked for me. But due to this ticket I looked closer, and while we allow % in general (this was fixed in 0.9.14.1 I believe…) there's special checks remaining for %22 %27 %3C and %3E (≠'").

I believe I left those in as a second line of defense. To be fixed.

comment:2 Changed 5 years ago by zzz

Resolution: fixed
Status: acceptedclosed
Note: See TracTickets for help on using tickets.