Opened 4 years ago

Closed 4 years ago

#1419 closed defect (worksforme)

Bind error - Address already in use.

Reported by: thebland Owned by: str4d
Priority: minor Milestone: 0.9.18
Component: apps/android Version: 0.9.17
Keywords: Cc:
Parent Tickets:

Description

Getting the following error in my logs on the I2P for Android. I can't find anything that is also using localhost. Irc works find so it is maybe a port issue?

12/04 21:12:51.963 ERROR [Client 10 ] .i2ptunnel.I2PTunnelHTTPClient: Error listening for connections on 4444
java.net.BindException?: bind failed: EADDRINUSE (Address already in use)

at libcore.io.IoBridge?.bind(IoBridge?.java:99)
at java.net.PlainSocketImpl?.bind(PlainSocketImpl?.java:132)
at java.net.ServerSocket?.<init>(ServerSocket?.java:105)
at net.i2p.i2ptunnel.I2PTunnelClientBase.run(I2PTunnelClientBase.java:629)
at java.lang.Thread.run(Thread.java:818)
at net.i2p.util.I2PThread.run(I2PThread.java:84)

Caused by: android.system.ErrnoException?: bind failed: EADDRINUSE (Address already in use)

at libcore.io.Posix.bind(Native Method)
at libcore.io.ForwardingOs?.bind(ForwardingOs?.java:56)
at libcore.io.IoBridge?.bind(IoBridge?.java:97)
... 5 more

App version: 0.9.17
Android version: 5.0
Model: Nexus 5

Subtickets

Change History (3)

comment:1 Changed 4 years ago by str4d

That would only happen if something else was already listening on port 4444. I doubt it would be I2P Android, unless I2PTunnel somehow managed to start and then lose the HTTP tunnel.

  • Have you tried accessing eepsites on the localhost:4444 proxy? If you get the error but that still works, it is an I2PTunnel issue.
  • Does this happen every time you start I2P Android?

comment:2 Changed 4 years ago by thebland

  • Priority changed from blocker to minor

I have been unable to reproduce the error in the ticket. Originally I:

  1. Installed I2P from the Play Store.
  2. Started I2P.
  3. Looked at configuration settings for various browsers and chose Orweb.
  4. Installed Orweb
  5. Changed proxy port on Orweb.
  6. Tried to browse to zzz.i2p and got proxy error.

Further investigation showed the above error multiple times in I2P logs files.

I then tried to log into IRC which worked fine.

Not sure why it started working all of a sudden but I did various things like stop/start I2P and exiting enter Orweb multiple times without fixing the issue. Could be I killed both apps in the app settings and that did the trick. I guess this can be closed unless someone else reports the same error.

comment:3 Changed 4 years ago by str4d

  • Resolution set to worksforme
  • Status changed from new to closed

There isn't much we can do here without more data. Closing until we have something else to suggest there is a problem.

Note: See TracTickets for help on using tickets.