Opened 5 years ago

Closed 5 years ago

#1439 closed defect (not a bug)

I2PSnark: Torrents' total reported size and ETA do not exclude skipped files

Reported by: somewon Owned by: zzz
Priority: minor Milestone: undecided
Component: apps/i2psnark Version: 0.9.17
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

I2PSnark gives a great option to Skip files within a torrent that we don't want. However, in the main display, it still shows the download progress in terms of the total size of the original torrent, even if a large amount of data is set to Skip. I think it would be nice if it re-calculated the size of the torrent and its ETA to exclude all files set to Skip. All other torrent clients that I've used do this effectively.

Thanks once again to all the terrific devs for such an amazing suite of software!

Subtickets

Change History (4)

comment:1 Changed 5 years ago by zzz

Hmm I thought it did everything correctly. I'll check.

comment:2 Changed 5 years ago by zzz

Status: newinfoneeded_new

I just started a large video torrent and skipped all the files except for a small ~10 MB "sample" video file. The ETA is reported correctly, showing about 15 minutes remaining when the down rate was ~ 10 KBps.

The total size shown is indeed the total size of the torrent, not the total of the non-skipped files. That's by design. I couldn't think of a good way to display that information, and I don't think it's necessary.

Please retest. If you still see a problem please report your I2P version number and any other important details. If you don't see a problem after all, please close the ticket.

comment:3 Changed 5 years ago by somewon

Status: infoneeded_newnew

What timing, I was just coming back here to correct the ticket! I did indeed just see that the ETA is reported correctly, I apologize for the mistake. I would still prefer the size displayed to be the non-skipped data, but I don't feel strongly about it at all, and I can respect the decision to keep it as is by design.

Closed!

comment:4 Changed 5 years ago by somewon

Resolution: not a bug
Status: newclosed
Note: See TracTickets for help on using tickets.