Opened 4 years ago

Last modified 4 years ago

#1442 accepted defect

eepget batch script in windows does not expect spaces in %JAVA% variable

Reported by: djjeshk Owned by: killyourtv
Priority: minor Milestone: 0.9.18
Component: installer Version: 0.9.17
Keywords: Cc:
Parent Tickets:

Description

Tried to download something using eepget batch script, but this strange error appears:

'and' is not recognized as an internal or external command,
operable program or batch file.

It can be fixed by typing double quotes around all paths.

Subtickets (add)

Change History (1)

comment:1 Changed 4 years ago by killyourtv

  • Component changed from other to installer
  • Milestone changed from undecided to 0.9.18
  • Owner set to killyourtv
  • Status changed from new to accepted

Interestingly, in English language versions of Windows, Java is installed to C:\Program Files or C:\Program Files (x86) and it worked there. I guess you're setting the JAVA variable in the batch file yourself? If so, yes, you need to quote the value due to "that being the way it is".

With all that said, there should probably be more quoting done throughout.

Note: See TracTickets for help on using tickets.