Opened 5 years ago

Closed 5 years ago

#1472 closed defect (fixed)

0.9.17-xx : iMule crash the first time launched, then work when launched the second time

Reported by: hummingbird Owned by: mkvore
Priority: trivial Milestone: undecided
Component: apps/SAM Version: 0.9.17
Keywords: imule Cc:
Parent Tickets: Sensitive: no

Description

Since I run 0.9.17-xx betas, I noticed that several times (perhaps always) my iMule crash the first time I launch it (it freeze for some minutes then crash), but work fine the second time I launch it.

In the following example, I launched I2P, waited 3 minutes, launched imule, it stayed freeze for 8 minutes then crashed. Then I launched again imule and it worked (it has open and connected to I2P).

It's iMule v2.3.2.3 , OS Windows 7.

12/02/15 23:04:25 ERROR [HelloHandler?] net.i2p.sam.SAMBridge : SAM error: Timeout waiting for HELLO VERSION
net.i2p.sam.SAMException: Timeout waiting for HELLO VERSION

at net.i2p.sam.SAMHandlerFactory.createSAMHandler(SAMHandlerFactory.java:56)
at net.i2p.sam.SAMBridge$1HelloHandler.run(SAMBridge.java:509)
at java.lang.Thread.run(Unknown Source)
at net.i2p.util.I2PThread.run(I2PThread.java:84)

Caused by: java.net.SocketTimeoutException?

at sun.nio.ch.SocketAdaptor?$SocketInputStream?.read(Unknown Source)
at sun.nio.ch.ChannelInputStream?.read(Unknown Source)
at java.io.InputStream?.read(Unknown Source)
at sun.nio.ch.ChannelInputStream?.read(Unknown Source)
at net.i2p.data.DataHelper?.readLine(DataHelper?.java:1436)
at net.i2p.data.DataHelper?.readLine(DataHelper?.java:1333)
at net.i2p.data.DataHelper?.readLine(DataHelper?.java:1300)
at net.i2p.sam.SAMHandlerFactory.createSAMHandler(SAMHandlerFactory.java:48)
… 3 more

I2P version: 0.9.17-23
Java version: Oracle Corporation 1.8.0_31 (Java™ SE Runtime Environment 1.8.0_31-b13)
Wrapper version: none
Server version: 8.1.16.v20140903
Servlet version: Jasper JSP 2.1 Engine
Platform: Windows 7 x86 6.1
Processor: (athlon64)
Jbigi: Locally optimized native BigInteger? library loaded from file

Subtickets

Attachments (1)

graphs_screenshot.png (302.3 KB) - added by hummingbird 5 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 5 years ago by hummingbird

My internet connection sometimes lags, and I noticed that this was the case in this report (I had "Message delay" up to 2000 ms).

Changed 5 years ago by hummingbird

Attachment: graphs_screenshot.png added

comment:2 Changed 5 years ago by hummingbird

The screenshot shows I2P's graphs after the issue, when iMule is running fine again.

comment:3 Changed 5 years ago by hummingbird

Priority: minortrivial
Status: newtesting

After more tests, I am sure that my issue is caused by my (often) unstable internet connection.

comment:4 Changed 5 years ago by hummingbird

Resolution: fixed
Status: testingclosed
Note: See TracTickets for help on using tickets.