Opened 4 years ago

Closed 4 years ago

#1486 closed defect (not a bug)

i2psnark sometimes fails to write pieces

Reported by: root Owned by: zzz
Priority: major Milestone: undecided
Component: apps/i2psnark Version: 0.9.18
Keywords: Cc:
Parent Tickets:

Description

the error message in i2psnarks looks like that :
"Fatal storage error: Stopping torrent XXXXXXXXXXXXXXXX
Error writing storage (piece 1214) for XXXXXXXXXXXXXXXX: java.io.IOException: Error writing '/path/to/file'

then the torrent stops and on every restart of the torrent, it stops at the same piece with the same error. The error appears almost everytime just before the torrent finishes leaving it unuseable ...

here is the whole stackstrace out of the log-files of i2p :
java.lang.RuntimeException?: Error writing storage (piece 1214) for XXXXXXXXXXXXXXXX: java.io.IOException: Error writing XXXXXXXXXXXXXXXX

at org.klomp.snark.PeerCoordinator?.gotPiece(PeerCoordinator?.java:1021)
at org.klomp.snark.PeerState?.pieceMessage(PeerState?.java:316)
at org.klomp.snark.PeerConnectionIn?.run(PeerConnectionIn?.java:154)
at org.klomp.snark.Peer.runConnection(Peer.java:304)
at org.klomp.snark.PeerCoordinator?$1.run(PeerCoordinator?.java:604)
at java.lang.Thread.run(Thread.java:745)
at net.i2p.util.I2PThread.run(I2PThread.java:84)

Caused by: java.io.IOException: Error writing XXXXXXXXXXXXXXXX

at org.klomp.snark.Storage.putPiece(Storage.java:1059)
at org.klomp.snark.PeerCoordinator?.gotPiece(PeerCoordinator?.java:999)
... 6 more

Caused by: java.io.IOException: Bad file descriptor

at java.io.RandomAccessFile?.writeBytes0(Native Method)
at java.io.RandomAccessFile?.writeBytes(RandomAccessFile?.java:520)
at java.io.RandomAccessFile?.write(RandomAccessFile?.java:550)
at org.klomp.snark.PartialPiece?.write(PartialPiece?.java:255)
at org.klomp.snark.Storage.putPiece(Storage.java:1056)
... 7 more


#java -version
java version "1.7.0_60"
Java(TM) SE Runtime Environment (build 1.7.0_60-b19)
Java HotSpot?(TM) Client VM (build 24.60-b09, mixed mode)


#uname -msipr
Linux 3.8.13.28 armv7l unknown ODROID-U2/U3

the error only happens on my arm router ... so it seems related
keep up the awesome work ;)

Subtickets

Change History (3)

comment:1 Changed 4 years ago by zzz

<iRelay> <user@kyirc> that's exactly what I had a few days ago, root
<iRelay> <user@kyirc> and it is likely some bad sector on your hd
<iRelay> <user@kyirc> I stopped the torrent, moved it to another drive, readded it to i2psnark and it worked like a charm

comment:2 Changed 4 years ago by root

thx for the hint,
it seems that my external usb drive was draining to much power as the torrent completes
using a powered usb-hub seems to solve the problem
(i was able to download a torrent without stumbling upon the error again)

Bug can be closed, i think

Last edited 4 years ago by root (previous) (diff)

comment:3 Changed 4 years ago by zzz

  • Resolution set to not a bug
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.