Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1500 closed defect (not a bug)

Cannot start websites because of java connection limit

Reported by: DjJeshk Owned by:
Priority: major Milestone:
Component: apps/i2ptunnel Version: 0.9.18
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

I2P version: 0.9.18-11-rc
Java version: Oracle Corporation 1.8.0_31 (Java™ SE Runtime Environment 1.8.0_31-b13)
Wrapper version: 3.5.25
Server version: 8.1.16.v20140903
Servlet version: Jasper JSP 2.1 Engine
Platform: Windows XP x86 5.1
Processor: Core 2 (45nm) (core2)
Jbigi: Locally optimized native BigInteger? library loaded from file
Encoding: Cp1257
Charset: windows-1257

15.25.3 02:23:08 ↓↓↓ 1 similar message omitted ↓↓↓

15.25.3 02:23:00 ERROR [7.0.0.1:7658] .i2ptunnel.I2PTunnelHTTPServer: Error accepting
java.net.ConnectException?: ServerSocket? closed
at net.i2p.client.streaming.impl.ConnectionHandler?.accept(ConnectionHandler?.java:138)
at net.i2p.client.streaming.impl.I2PSocketManagerFull.receiveSocket(I2PSocketManagerFull.java:134)
at net.i2p.client.streaming.impl.I2PServerSocketFull.accept(I2PServerSocketFull.java:38)
at net.i2p.i2ptunnel.I2PTunnelServer.run(I2PTunnelServer.java:489)
at java.lang.Thread.run(Unknown Source)
at net.i2p.util.I2PThread.run(I2PThread.java:84)
15.25.3 01:28:30 ERROR [Timestamper ] net.i2p.util.Clock : Ignoring clock offset 249ms (current -11123ms) since it would increase peer clock skew from -2303ms to 9069ms. Bad time server?
15.24.3 23:34:12 ERROR [7.0.0.1:8888] .i2ptunnel.I2PTunnelHTTPServer: Error connecting to HTTP server /127.0.0.1:8888
java.net.SocketException?: No buffer space available (maximum connections reached?): connect
at java.net.TwoStacksPlainSocketImpl?.socketConnect(Native Method)
at java.net.AbstractPlainSocketImpl?.doConnect(Unknown Source)
at java.net.AbstractPlainSocketImpl?.connectToAddress(Unknown Source)
at java.net.AbstractPlainSocketImpl?.connect(Unknown Source)
at java.net.PlainSocketImpl?.connect(Unknown Source)
at java.net.SocksSocketImpl?.connect(Unknown Source)
at java.net.Socket.connect(Unknown Source)
at java.net.Socket.connect(Unknown Source)
at java.net.Socket.<init>(Unknown Source)
at java.net.Socket.<init>(Unknown Source)
at net.i2p.i2ptunnel.I2PTunnelServer.getSocket(I2PTunnelServer.java:687)
at net.i2p.i2ptunnel.I2PTunnelServer.getSocket(I2PTunnelServer.java:642)
at net.i2p.i2ptunnel.I2PTunnelHTTPServer.blockingHandle(I2PTunnelHTTPServer.java:295)
at net.i2p.i2ptunnel.I2PTunnelServer$Handler.run(I2PTunnelServer.java:573)
at java.util.concurrent.ThreadPoolExecutor?.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor?$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

Subtickets

Change History (2)

comment:1 Changed 4 years ago by zzz

Milestone: undecided
Resolution: not a bug
Status: newclosed

copied from http://zzz.i2p/topics/1851 thank you

this one is not our bug, it's a java limit/issue. Google for:

java.net.SocketException?: No buffer space available (maximum connections reached?)

apparently a windows thing?

comment:2 Changed 4 years ago by hummingbird

The issue reporter wrote later:

A little late but you can raise the max number of connections in windows XP.
http://www.megaleecher.net/Tcpip.sys_Patch_To_Increase_Windows_XP_Connection_Limit

"…By default Windows XP allows a maximum of 10 half open connections at a time, this limit is implemented as a security feature to slow-down spreading of internet-worms in-case the user machine gets infected, if your network use is crossing this limit your computers event-log will show the following Event: EventID 4226: TCP/IP has reached the security limit imposed on the number of concurrent TCP connect attempts…"

So maybe this is not a JAVA problem as stated in the bug report.

I want to add I have no connection to the program they use to change it. I just found the page by searching. Seemed to work for me.


I (Hummingbird) remember that old Windows "feature":

Note: See TracTickets for help on using tickets.