Opened 4 years ago

Closed 3 years ago

#1516 closed defect (no response)

Router freezes for about one minute on UPnP port map hang

Reported by: djjeshk Owned by: zzz
Priority: major Milestone: undecided
Component: router/transport Version: 0.9.18
Keywords: Cc:
Parent Tickets:

Description

I2P version: 0.9.18-18-rc
Java version: Oracle Corporation 1.8.0_31 (Java(TM) SE Runtime Environment 1.8.0_31-b13)
Wrapper version: 3.5.25
Server version: 8.1.16.v20140903
Servlet version: Jasper JSP 2.1 Engine
Platform: Windows XP x86 5.1
Processor: Core 2 (45nm) (core2)
Jbigi: Locally optimized native BigInteger? library loaded from file
Encoding: Cp1257
Charset: windows-1257

Router simply started to freeze for a long time with no appearent reason. When it finally released it shows job lag about 50 - 60 seconds.
Log does not show any helpful information.

I tried to run external UPnP port map utily, but it deadlocked too for a minute when i tried to add port mappings.

Another strange symptom was that network router does not gives back external IP address. PortMapper? 1.9.5 shows the following:
INFO Got internal host name '192.168.11.1' for router.
INFO Got external IP address null for router.
Clearnet sites works as expected.

Issue was resolved by reseting all network devices.

Subtickets

Change History (4)

comment:1 Changed 4 years ago by zzz

  • Component changed from other to router/transport
  • Owner set to zzz

If you can reproduce it, please take a thread dump during the hang.

comment:2 Changed 4 years ago by djjeshk

I tried to take thread dump first I saw this but router was completely unworkable like it was suspended by external tool.

I will not try to reproduce this to avoid network device permanent failure. But if you know any UPnP network device emulator, then this could be repeated.

As far as I remember, then UPnP port map operation is single send and single receive operation. It could deadlock only in case if network router does not receives or sends data as expected. I will look at i2p UPnP implementation to guess where this should happen.

comment:3 Changed 4 years ago by zzz

  • Status changed from new to infoneeded_new

Without a thread dump it's impossible to proceed on this. Returning to OP to either provide one or close as unreproducible.

comment:4 Changed 3 years ago by zzz

  • Resolution set to no response
  • Status changed from infoneeded_new to closed
Note: See TracTickets for help on using tickets.